summaryrefslogtreecommitdiff
path: root/dev-python/pushbullet-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/pushbullet-py
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/pushbullet-py')
-rw-r--r--dev-python/pushbullet-py/Manifest1
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.11.0-r1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pushbullet-py/Manifest b/dev-python/pushbullet-py/Manifest
index 56962889ad13..1bac7118054c 100644
--- a/dev-python/pushbullet-py/Manifest
+++ b/dev-python/pushbullet-py/Manifest
@@ -1,3 +1,4 @@
DIST pushbullet.py-0.11.0.tar.gz 21653 BLAKE2B a6c9b6f4958ce35b63ea4043d1d4f8691885bd0aa2927af541f2080a0b0b65a7df979a497967f3adceab8ad2382448a4c6a02d1184c9d72a18d91844eb970722 SHA512 b236f30b99e5bb79eff183529716c1c8f83cfd2526fdf50d86041eb6d3fcd6670d0c4dce407ae6e50aea0fa96d6a5527af980148f0c71ef758c480f972ad9659
+EBUILD pushbullet-py-0.11.0-r1.ebuild 1105 BLAKE2B ae3b7ce59c1410da02386eaa2f6aea342dea9cebd61aab57b66cde247d68a2d70ef694e2a27c914c5d418a273cb7cfe7d42cd5e3691eb23fdc599b99d63da15a SHA512 4f24b22cc00e423570bcd77db34433730119d5fb5018c1e21fa221cfc81adb05447c05a3e14286d81a870f29dfee978f3f18c5538233929d17949fabeedb0a0c
EBUILD pushbullet-py-0.11.0.ebuild 1130 BLAKE2B 614cf6a5ea5661cfb8748fc1376775c27e8d4d776229e38f2c0f26379fa33e2c5d937d7e31a18b9018ab6a65c4745a6b4e09a60cec7a8f37685a47c981be24b3 SHA512 a017d3919983d68b71b092dbb88311f27cd12fdd590afd36ec17dc45a0af7ebbcaf6ae0d1509a53df42b62f744d71569db99bc94c44a9894e3a81a5f435380a4
MISC metadata.xml 459 BLAKE2B 86e83479fde9503defd709e67ea6ba81e5dd9430e1e1b4ea6545f332979173fab9a2392528007638531c58ec205f2d45ca9817f21981b4ebd94f0f81596bde71 SHA512 cda083520abafb4b81b0691234a2bc2bbdf75f4bef69943e5243492a8d8916f9924eae5f06288a6f636ef7bf36477e198dc6a33a04e55a9fd2376a03999f91a2
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.11.0-r1.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..c1adf5146b15
--- /dev/null
+++ b/dev-python/pushbullet-py/pushbullet-py-0.11.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+DESCRIPTION="A simple python client for pushbullet.com"
+HOMEPAGE="https://github.com/randomchars/pushbullet.py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ # skip tests which require network access
+ PUSHBULLET_API_KEY= pytest -vv \
+ -k "not (test_auth or test_decryption)" \
+ || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r example/.
+ fi
+ distutils-r1_python_install_all
+}