summaryrefslogtreecommitdiff
path: root/dev-python/puremagic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/puremagic
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/puremagic')
-rw-r--r--dev-python/puremagic/Manifest3
-rw-r--r--dev-python/puremagic/metadata.xml13
-rw-r--r--dev-python/puremagic/puremagic-1.11.ebuild20
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/puremagic/Manifest b/dev-python/puremagic/Manifest
new file mode 100644
index 000000000000..767e222a3a24
--- /dev/null
+++ b/dev-python/puremagic/Manifest
@@ -0,0 +1,3 @@
+DIST puremagic-1.11.tar.gz 295026 BLAKE2B 4d210807d9f5eb0c2eb88b0c18aa5cdf56170b347de4f95b92c08492d5f038759b39c1aa2d6ed4bc91e96e036e6f4d0891449af8aee3beac65c4d692fa295ec0 SHA512 4d4c9a93cd56a02aefb7090c92b41048f33923bef14022158f39c39ac93326b7180b8cc97495ad5ed3eec7d9f1379a5508829ee779aaba9b8aa8f975e787b1f5
+EBUILD puremagic-1.11.ebuild 480 BLAKE2B d5eb484485a5d2193635909950a7b754c1fa2c5d5fa2c1364b314f444a0f32b00cf1a76957256f437e0b8e49e9cc913831dc7ce002ea7c799a6f86d59d9953b3 SHA512 c56f66d813b60dabd602328dedf6f79d47d46484382dab26fac82595f805f5b46a0846d6337458ce4b0f547797360c455caabb0f74df9ec224e8c5833ee31554
+MISC metadata.xml 452 BLAKE2B 3a92e247697a9b50d0ee083b1f4b9b89d7c01759fcf93f13deafc4f2ffb3798f6daa22fd1c2ef642becbc8f03b7ede86348e51cbe0d8fa06c940f99c9523b41d SHA512 ff07bf3513774e077100c43df3ca20f8330e91a855b54c2a1a47da8584b057c32efdbfca07ef5d8c1378b61d0bdd974a9144fd07f0abbc71b1340b811832a02f
diff --git a/dev-python/puremagic/metadata.xml b/dev-python/puremagic/metadata.xml
new file mode 100644
index 000000000000..9f2ecb2e4c49
--- /dev/null
+++ b/dev-python/puremagic/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/cdgriffith/puremagic/issues</bugs-to>
+ <remote-id type="github">cdgriffith/puremagic</remote-id>
+ <remote-id type="pypi">puremagic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/puremagic/puremagic-1.11.ebuild b/dev-python/puremagic/puremagic-1.11.ebuild
new file mode 100644
index 000000000000..7f02fc5c206e
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="https://github.com/cdgriffith/puremagic"
+SRC_URI="https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest