summaryrefslogtreecommitdiff
path: root/dev-python/pupynere
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pupynere
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pupynere')
-rw-r--r--dev-python/pupynere/Manifest3
-rw-r--r--dev-python/pupynere/metadata.xml15
-rw-r--r--dev-python/pupynere/pupynere-1.0.15-r1.ebuild27
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pupynere/Manifest b/dev-python/pupynere/Manifest
new file mode 100644
index 000000000000..7bae61423c1e
--- /dev/null
+++ b/dev-python/pupynere/Manifest
@@ -0,0 +1,3 @@
+DIST pupynere-1.0.15.tar.gz 8566 BLAKE2B 1780b7c17868b77c294da0f81052077be22b72660b472a29641c8390d34a608fb0dc067fe942dba764dd5735ce034981c9b5e3b47825eb3be9ab94e46a71d972 SHA512 55b25ca4fb511d80b5eb11b8aa63949c80e9dda336ed1ad406314bbda669ee4ef836a3e01b71065eec0cf0b8556ef36c815a299a5620d50983074a2ff55ca5ba
+EBUILD pupynere-1.0.15-r1.ebuild 646 BLAKE2B 94efb0dcc790656738a64c3d9ea0aeed278eda52757de41efc619c7c6c726fbac0558f98cd059aa220c8deaa6e6a2a0e9bdb5ccd52762213b6a7f251f6dcab7a SHA512 6920cebd6d28479bf0236df2d678c7c796a7c5229e63da2b75a185f405011c50aacf2fc78ab063fb5282bb89e50f78cd8edc502e183c4c7ae3557ed7d8fbb291
+MISC metadata.xml 500 BLAKE2B 27412e37a799d7931fb1f7d5dc712db7d6d25f44e166d7a045c63ed3c1f978f1dbbd15facea31d258154f6fe689cf148fee71acc33f6b653f4b9d0388c51ce44 SHA512 7aff7144c2be483bf339a2bc43fec68bde804bc43b1f13a462bd7cd617b53884de2791b6a3335fd90b38d01ce081b1246281d068254af0722731cafa17381e91
diff --git a/dev-python/pupynere/metadata.xml b/dev-python/pupynere/metadata.xml
new file mode 100644
index 000000000000..e6468d3c792f
--- /dev/null
+++ b/dev-python/pupynere/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pupynere is a Python module for reading and writing NetCDF files,
+ using the same API as Scientific.IO.NetCDF and pynetcdf.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pupynere</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pupynere/pupynere-1.0.15-r1.ebuild b/dev-python/pupynere/pupynere-1.0.15-r1.ebuild
new file mode 100644
index 000000000000..044e5cb45895
--- /dev/null
+++ b/dev-python/pupynere/pupynere-1.0.15-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pupynere is a PUre PYthon NEtcdf REader"
+HOMEPAGE="https://pypi.org/project/pupynere/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" -m doctest -v "${BUILD_DIR}"/lib/pupynere.py \
+ || die "Tests fail with ${EPYTHON}"
+}