summaryrefslogtreecommitdiff
path: root/dev-python/pulsectl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
commit345c02ca33341652116ddec6705530223af2de85 (patch)
treebcb9923530ba0703557f280b0a2bd1343bae857c /dev-python/pulsectl
parentf300354de9fe5d997850456a9e1f400193e6544f (diff)
gentoo auto-resync : 27:08:2024 - 12:00:02
Diffstat (limited to 'dev-python/pulsectl')
-rw-r--r--dev-python/pulsectl/Manifest2
-rw-r--r--dev-python/pulsectl/pulsectl-24.8.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pulsectl/Manifest b/dev-python/pulsectl/Manifest
index 37b57031d5de..58da4cda1c22 100644
--- a/dev-python/pulsectl/Manifest
+++ b/dev-python/pulsectl/Manifest
@@ -1,3 +1,5 @@
DIST pulsectl-24.4.0.tar.gz 41166 BLAKE2B 3b2d41b3077f050104e7b416cb8dbba47f4282bb90ee58c855f4f5a1e1b1183b131879e6965edf8d8b5a2466ce3381e45c7a6b92f2b64fc336d311d3d7625440 SHA512 b17fd577f9c336f762925bd423fdca665afa92a88b0dae076ca016d7c5b2b3d9ef11efd27f7339031accadef00d513f972c216a23f26cfd049516f3dbcc63d01
+DIST pulsectl-24.8.0.tar.gz 41171 BLAKE2B 58a16b07fcec68f21fd573cf781f2ac09ccdf2faa3e7afa84a4f8cf9f28111e94bf41e0f8a8740434edeace78156f56ac428a87d669cbc947e331b8d555dd2e1 SHA512 4638bb41611e8d7a00f2daeec7e7783789d5d1d94841206b4052e53897e6547c21f8410c3400e1bd301e237b3a72143fb6ff3d67cbafd06bada0a1d0da007c96
EBUILD pulsectl-24.4.0.ebuild 581 BLAKE2B bc378c0e1bd52ebdedf5ddc03c39ba9633854762e9a0cf052290b36c39bde68b309795b484d67914daba443fe564b6ac2e5d1fe7476ed5d3af6d7c5d74b93821 SHA512 a35c5890c05541cb18b0d3e95c422843ad925729194627507f3923592025cbcd3cb04ec4d707b1611f2778d5b5269f303286bdf851fccb2931b0cbae279db798
+EBUILD pulsectl-24.8.0.ebuild 582 BLAKE2B cf21cc4a02e86d920853c2342bab24250fe58ff85d04d36ea2a62625937d642d0a2fe2d75ba6f515ee5d0ccf44ab2915777e2c80e12328b7680a22c23eb42f60 SHA512 82928301f96ea5491747ff46103bceb9153f8e3ae744564ad0515027d8dc49b014756f58bad2c6a933304518869b9b26dda6510fe760f5a0a6126bb7fd6e61b5
MISC metadata.xml 558 BLAKE2B 6cdebbc1f507bbab92256bbac867a86468b733b40dacfdb71090738f5505ea6ac33b24cbeb06835e10d9845e3fd9189a6c34625176f12c9dc7f4a1511069e8fe SHA512 b15eaa0564bc6dadf8d46eab154d028b4cbde26fa099793aa23df8f82eba86a4125d173eca8a8d2d73359dc67171dca9d8716e1495168c7b6c8ff5c701a21577
diff --git a/dev-python/pulsectl/pulsectl-24.8.0.ebuild b/dev-python/pulsectl/pulsectl-24.8.0.ebuild
new file mode 100644
index 000000000000..693b086854aa
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-24.8.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="
+ https://github.com/mk-fg/python-pulse-control/
+ https://pypi.org/project/pulsectl/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ media-libs/libpulse
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests unittest