summaryrefslogtreecommitdiff
path: root/dev-python/pulsectl-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-07 12:29:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-07 12:29:08 +0100
commit6c1090c8458fa6e15fd24227293d60bbf356eb60 (patch)
tree26a7d6ff13e906f3f47a6aca8e915c84b8f25bd0 /dev-python/pulsectl-asyncio
parent8bf02d8edf7e8947a205e2dca77bee4c4e31739b (diff)
gentoo auto-resync : 07:09:2024 - 12:29:07
Diffstat (limited to 'dev-python/pulsectl-asyncio')
-rw-r--r--dev-python/pulsectl-asyncio/Manifest2
-rw-r--r--dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pulsectl-asyncio/Manifest b/dev-python/pulsectl-asyncio/Manifest
index 02863acd3cbd..61d80833b62f 100644
--- a/dev-python/pulsectl-asyncio/Manifest
+++ b/dev-python/pulsectl-asyncio/Manifest
@@ -1,3 +1,5 @@
DIST pulsectl-asyncio-1.2.0.gh.tar.gz 19517 BLAKE2B 919909acfabfefa1dbea99cef6285483652649c111df6f3f6719d92e35ea548b54e6c0a60e4277b69610ee9a58c2c29c3355b7f2fe2780d773aa2c89513ce9a1 SHA512 b560c38b6d18a4c73551ae4ba34243f0043dc18426141c128c6ca3e8bd30f4d94d8718c3003ae506be038bc645ee569b77e6289b97ac913daa1e42e6b9aef03b
+DIST pulsectl-asyncio-1.2.1.gh.tar.gz 19531 BLAKE2B 4a3275d75602907f91b3a0979ff8908f4fa23bcf5d1d04068f878fc477011258180cec8ef16b6e6ebe6cc1713ff493841686cc67c4990222c061aa1b722199ff SHA512 b22d0a634433d558860ff1590020ba7272412be97da478a8b00ec457506cb58353b645537ae26591f1aed300cacc14fd0f50c8a3a0c7d650d610b24cc52248ee
EBUILD pulsectl-asyncio-1.2.0.ebuild 834 BLAKE2B dcdc4f12978faeae46557ce654e50c79a139b0a69282244b3ac642a4e7ef48aee25a9178a745e9d3fb25b0c60fd5de149251ff167cce852c99ace0c984ea9c6a SHA512 cf0cbf084c73d16e33a048d66d09ed6c2d4d15d0a33e62e73500b9c161ff184fab724c32af73cefe5d446a22cb547374c17fa8c180db0c98116c1f1cc8bb009a
+EBUILD pulsectl-asyncio-1.2.1.ebuild 835 BLAKE2B 8bea278459593288a9adbd156f5fa252f51ed4113dd441982fc31bbaf3d6a1c9eae3ff7e2e3e823ffa74814ba61c09294e9fcd57298f8aeef65823f343143717 SHA512 fcb431dd74a6e3f1dd7c47c3724802ef33f8f81bd20657aec60f6fdc4889fda79d16c542789d06a922d1cb47ec71e29820f81645d65217d6d0d2bd97a7a6dd6a
MISC metadata.xml 386 BLAKE2B 146d1d23a6622335b70d3e29d735aea6db1b2c6575678a308c8e4c83e52250bef36cfd6965cd1a77d5fd7dde89faa8c6cf6f024d7c6b83b95b2fb6259dafb2de SHA512 23c46c37c1a2a086e8e7ac67f9d8d8922b4f0b595dcf7cc2a6acddd187055beb3c96dac212f3ee749c20095e10acbab5e56e859122c62623065b04c4b2745f41
diff --git a/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.1.ebuild b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.1.ebuild
new file mode 100644
index 000000000000..8b6cfcbfc7dc
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio frontend for pulsectl, Python bindings of libpulse"
+HOMEPAGE="
+ https://github.com/mhthies/pulsectl-asyncio/
+ https://pypi.org/project/pulsectl-asyncio/
+"
+# sdist is missing examples that are used in tests
+SRC_URI="
+ https://github.com/mhthies/pulsectl-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pulsectl-23.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:,<=[0-9.]*::' setup.cfg || die
+ distutils-r1_src_prepare
+}