summaryrefslogtreecommitdiff
path: root/dev-python/ptpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ptpython
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ptpython')
-rw-r--r--dev-python/ptpython/Manifest4
-rw-r--r--dev-python/ptpython/metadata.xml12
-rw-r--r--dev-python/ptpython/ptpython-0.33-r1.ebuild34
-rw-r--r--dev-python/ptpython/ptpython-0.33.ebuild34
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/ptpython/Manifest b/dev-python/ptpython/Manifest
new file mode 100644
index 000000000000..95466d67e25a
--- /dev/null
+++ b/dev-python/ptpython/Manifest
@@ -0,0 +1,4 @@
+DIST ptpython-0.33.tar.gz 43295 BLAKE2B 96df547c3a231124e2e34e5dd6d6a2fe661883d8c8f88a25d955c46b250b86319e343adc0a2265841ca69f115e9b0787a431c49db9de2de362cd5d0c4334ae1f SHA512 fce9379e4522b2b644e6159c73e3eff2d0ced8de65462d4ad622f91feb46fa80a9e01a2c7aef1832b4fcf69de5c0c7d229c731149af7029eec46f88a0506ad71
+EBUILD ptpython-0.33-r1.ebuild 802 BLAKE2B fb6b4bb8ecfff858e8d3b6b69eedc2e43d77d690294249a8456413a919aad0615c798db7d30a8183fc9c3a5399a1d36958bce70bf01d79c3e7f588e192063d56 SHA512 6ce437e160e5ecd66bb69d41aa3e15fcbab5df4b92ee5291ea51ffa602bdf33b44192ef5fd06c79fde68a3bbd8fcba87806a9e5fca6e5bd3c979cc8ce11ab7fc
+EBUILD ptpython-0.33.ebuild 799 BLAKE2B 99519bb7f134f5f4c3deb61932fda9f8172840822efcf9f60a6971fdbdcdf8a3e7cdc9264d4ecbcbbd1e1413144530363add904a50b13b2cd521b01ff40a7571 SHA512 b25e1544c7e5bdae4a26441bfd9082d7634aec58aa824717e8add52c2b3f263d43b5b731ce9240357349450f48e2f28c4a1195e43f811c18a85facf367b4bd3b
+MISC metadata.xml 388 BLAKE2B eaff78614b0ada3d98f6f4e2ac1d4043845c62fb879fa894ae07f9b36a51b8226e541fba946757a6d34874ead2622b9fe0a726a6e12388579ba107f30d8282e8 SHA512 c64bb500332e8c5efffaa07034a3a86e0b5ca167a42fc030662562fce80ea69c53f4fe9b4a12a192d2faf693747c981500d4950cbb68fbc069050a5f61c9aa83
diff --git a/dev-python/ptpython/metadata.xml b/dev-python/ptpython/metadata.xml
new file mode 100644
index 000000000000..f08e580eb251
--- /dev/null
+++ b/dev-python/ptpython/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ptpython</remote-id>
+ <remote-id type="github">jonathanslenders/ptpython</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ptpython/ptpython-0.33-r1.ebuild b/dev-python/ptpython/ptpython-0.33-r1.ebuild
new file mode 100644
index 000000000000..72e732eec88a
--- /dev/null
+++ b/dev-python/ptpython/ptpython-0.33-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python REPL build on top of prompt_toolkit"
+HOMEPAGE="https://pypi.org/project/ptpython/ https://github.com/jonathanslenders/ptpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-0.58[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Not included
+RESTRICT=test
+
+python_test() {
+ "${PYTHON}" tests/run_tests.py || die
+}
diff --git a/dev-python/ptpython/ptpython-0.33.ebuild b/dev-python/ptpython/ptpython-0.33.ebuild
new file mode 100644
index 000000000000..3ae04d778f12
--- /dev/null
+++ b/dev-python/ptpython/ptpython-0.33.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python REPL build on top of prompt_toolkit"
+HOMEPAGE="https://pypi.org/project/ptpython/ https://github.com/jonathanslenders/ptpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-0.58[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Not included
+RESTRICT=test
+
+python_test() {
+ "${PYTHON}" tests/run_tests.py || die
+}