summaryrefslogtreecommitdiff
path: root/dev-python/psutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-19 11:57:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-19 11:57:35 +0100
commit6031cee8b35a5f0d7a1fee157d2cefcc05649608 (patch)
tree5c0c42caeec5e4a3c894667d689aad19aaf7ba1f /dev-python/psutil
parent59f8187afe529efeffdc2f967c451b159da44d5c (diff)
gentoo auto-resync : 19:04:2023 - 11:57:35
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/Manifest3
-rw-r--r--dev-python/psutil/psutil-5.9.5.ebuild46
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index bd14772a22a0..fe3295b9cedb 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -1,4 +1,7 @@
DIST psutil-5.9.3-tests-r1.patch.xz 3648 BLAKE2B df56e3b11da307fdd4441284d1a7928c928b36c512ef05d313ac71e76545eabaca1f6a1ea9dab301c86005ef4c9af9622e0d1c6d7be858b92b0dce9d6031440d SHA512 0d8b35fe76b1caf1265ab4ecf182c92b71714be9612418c945f39c58f384979ed36e47bdf11b11a8cf2fc3925fed60abadf4f3eaea083f6bcd6d2cddb81fb5f9
DIST psutil-5.9.4.tar.gz 485825 BLAKE2B ce5257e653876fc0c4bb005c964f677c0b4010f853cc7b8ff3451aa1efd7fde6b7e5d2150fb936cd38b667d5c167f180d5cae0792bdf50a8aa2e528795ed9897 SHA512 ff8d6213b153b5a3428e4f65ddbc41cb1f37caae4acab02760632107d95a50a74d3ee563f0cb2d623b37cdddd16425d2084e7f841e4a46af8988a7676f6975e6
+DIST psutil-5.9.5-tests.patch.xz 3664 BLAKE2B 9dfa9d8d4075c19939057a10be318292cae3feecd000aa594d3352fb92c3531c5bf491ce4b3807102181025975b21a9b88592eae7211e6717519a054a5030ddd SHA512 f29e4c6d8325a145b3f9768b98977b990bcc312c1323e189976163c1263b609af0d9b26b3bd7bf1ffe22468067a343822fde9ef765f7b48701fdf62f1774027b
+DIST psutil-5.9.5.tar.gz 493489 BLAKE2B 3db8ce374d9d81dcddc08f03418675318c5e447f9a3347154d025537ba090811926ced822f83ff5fc9239665b091803a30d167465495049569c3c820f7fbb32d SHA512 2afe1bad5359aeac90378faaa609bab855dfcaa58519c939fdadb02e6e2c8157c77f961ac0f90d104626cef3429e1ea2f686e4dc4c9dccf975e3e73e9b08872c
EBUILD psutil-5.9.4.ebuild 1210 BLAKE2B 8fc5f64b77ab7f704ac33f64bfd67d2fd411a07b526ede09e120f81e855edb7b7e868d84ff72d58a504ee48a16e5c5721c4b4b4a22846037d03db79229ba0096 SHA512 0486ef275acf2b495546f735ffb44858464915f340964b9189e8a57088db8a2eca9558a5d109569331c6195cebdbf8fd6875d2914befc5cde65fac4c395dce06
+EBUILD psutil-5.9.5.ebuild 1215 BLAKE2B 3e8cacb89172831a6a6be99a5a81d963752cdff78e532192e813f14bfbefd8ed793bb823324aa77f66949ba2ee3db78c8cd3bbb028801c03f678c13ce23d7207 SHA512 1468b65a822139ef68334a8d124d5a7778e2021c64a7dee9505f2750826fcb76123f156a7983b771615a2e36275868cbb71117e1efcf91590edbcec5bb6bf1c8
MISC metadata.xml 378 BLAKE2B 235c056a427ab18383c401143074ec62b91d471087c34e2bd48d5192c6221e089e32170d18cd0d69d51eb2bb02fb8a0efe59245af9224b284557812b32c341b5 SHA512 96492308dac753fb176e4810efa71757e66413d16589e52a942b02c91256b48f9873b53a698006923aef12aa7d1539d6fd7aa07632c073b6a92cc8920f6ce6c0
diff --git a/dev-python/psutil/psutil-5.9.5.ebuild b/dev-python/psutil/psutil-5.9.5.ebuild
new file mode 100644
index 000000000000..a12878b0bdfa
--- /dev/null
+++ b/dev-python/psutil/psutil-5.9.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+TEST_PATCH=psutil-5.9.5-tests.patch
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="
+ https://github.com/giampaolo/psutil/
+ https://pypi.org/project/psutil/
+"
+SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${TEST_PATCH}.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${WORKDIR}/${TEST_PATCH}"
+)
+
+python_test() {
+ # Since we are running in an environment a bit similar to CI,
+ # let's skip the tests that are disabled for CI
+ local -x TRAVIS=1
+ local -x APPVEYOR=1
+ local -x GITHUB_ACTIONS=1
+ local -x GENTOO_TESTING=1
+ "${EPYTHON}" psutil/tests/runner.py ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_compile() {
+ # Force -j1 to avoid .o linking race conditions
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}