summaryrefslogtreecommitdiff
path: root/dev-python/psutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-19 07:57:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-19 07:57:57 +0100
commit27f7ac2204449d9fc2137f442522b4fb10327d90 (patch)
treee0fa5de044037be9ff62dcb6bcc8dbeca087767d /dev-python/psutil
parent84a400be40cf32d9e536ae34ebf14ad06ad6b8d6 (diff)
gentoo auto-resync : 19:10:2022 - 07:57:56
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/Manifest3
-rw-r--r--dev-python/psutil/psutil-5.9.3.ebuild47
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index 97f57dcca88f..dcee9d93b42c 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -1,4 +1,7 @@
DIST psutil-5.9.1-tests-r2.patch.xz 3516 BLAKE2B 6a16d6f89fdeb06c7aa0d9d986eba84deae5f8d2bb829c2509744f954f9b274d8a70a00f94127f1880cea71f8d7e7b85097517f8516ee6ef14f17522ee9297b2 SHA512 b69efb32cd0229056ff9fbbde963f0f01f6bf1d0820f028527f464e38a9bd4211a55bd725cc8962a20608c12c28edb24b2063f5f58b53fdb6b001fe2f95da103
DIST psutil-5.9.1.tar.gz 479090 BLAKE2B 88f35a9134d942fa56b5fbc79753e82245c3bfdb1f640dbf3b56815b89d872517f9ee3a3945532ebd1a399c3307e160ac80394766c3b2cc7e3fb36ffdd555eef SHA512 1ddb119a10243d17d808417817ec8659d22447f12a4bbc0366c13f6587a4b0b59f4e74f6ac5d1e1a908bb5fd287be630466d32beabcb5008f6a19c24a1557c27
+DIST psutil-5.9.3-tests-r1.patch.xz 3648 BLAKE2B df56e3b11da307fdd4441284d1a7928c928b36c512ef05d313ac71e76545eabaca1f6a1ea9dab301c86005ef4c9af9622e0d1c6d7be858b92b0dce9d6031440d SHA512 0d8b35fe76b1caf1265ab4ecf182c92b71714be9612418c945f39c58f384979ed36e47bdf11b11a8cf2fc3925fed60abadf4f3eaea083f6bcd6d2cddb81fb5f9
+DIST psutil-5.9.3.tar.gz 483579 BLAKE2B c1b5c77483a1e280cc68aa3ae5ca39fcc3992f3c07a591bbe92278050e9517a9e9c0e17338f2932f5ec680a19c4f6958e21e4b9b02158041e76dd877b5311c21 SHA512 d226364b416823783058f19c06dae4ac1ea03f061646f01ea6953ded8fbb89aed92aa743c9e55181e4d57101f7dbbb78336043e1fc7a3bd62ff82b19f0a4efae
EBUILD psutil-5.9.1.ebuild 1242 BLAKE2B 0b8bc2e058d875c436e51dda98773cebdc0acf1feed749edf3814c752c7d2bd01163a7e0dc39366772aaa25de124c6cd3caceabc5af98abe918b2ae8def710ae SHA512 b2fb3b749cb2b45296bf2b42d9253ae47887213d5ae750e489be469d9d8e0ddd6a68a0b00c8c27dd2a7982fda46fad4d291ea429d8e921b7f717950d68039bbe
+EBUILD psutil-5.9.3.ebuild 1255 BLAKE2B f740459a556efa90ff8b4344ca879dd631087a032d0498aa580d0482f88cad33df5583c9ea79864b82ac57f94a1b618fbe2e317932dade7d528e40dd5ce22c66 SHA512 e71b2442d4f1c9af8436462f1bc84f3605c82ec2c29e63b35136f6efe338dc8677a0421e92721511357aeeb1cf593c706b8195cf245534119c28e12755f236d9
MISC metadata.xml 378 BLAKE2B 235c056a427ab18383c401143074ec62b91d471087c34e2bd48d5192c6221e089e32170d18cd0d69d51eb2bb02fb8a0efe59245af9224b284557812b32c341b5 SHA512 96492308dac753fb176e4810efa71757e66413d16589e52a942b02c91256b48f9873b53a698006923aef12aa7d1539d6fd7aa07632c073b6a92cc8920f6ce6c0
diff --git a/dev-python/psutil/psutil-5.9.3.ebuild b/dev-python/psutil/psutil-5.9.3.ebuild
new file mode 100644
index 000000000000..609517d00b2f
--- /dev/null
+++ b/dev-python/psutil/psutil-5.9.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+TEST_PATCH=psutil-5.9.3-tests-r1.patch
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="
+ https://github.com/giampaolo/psutil/
+ https://pypi.org/project/psutil/
+"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~mgorny/dist/${TEST_PATCH}.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${WORKDIR}/${TEST_PATCH}"
+)
+
+python_test() {
+ # Since we are running in an environment a bit similar to CI,
+ # let's skip the tests that are disabled for CI
+ local -x TRAVIS=1
+ local -x APPVEYOR=1
+ local -x GITHUB_ACTIONS=1
+ local -x GENTOO_TESTING=1
+ "${EPYTHON}" psutil/tests/runner.py ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_compile() {
+ # Force -j1 to avoid .o linking race conditions
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}