summaryrefslogtreecommitdiff
path: root/dev-python/psutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/psutil
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/Manifest3
-rw-r--r--dev-python/psutil/psutil-5.9.1.ebuild44
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index b7ee3d49025f..d9253b450dda 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -1,4 +1,7 @@
AUX psutil-5.9.0-tests.patch 12930 BLAKE2B 486e8b5316cda0aa7b03f803a76d800a6c40fe1188de1dcf334710fc4e1a53b759759956af0397ccd2afe75cb476b76f0b84675b517b74505b0889e512a593a7 SHA512 b9b67f5adfcd64693e5492ed6c03c0af8faf926a4091c0728e5f409bc3d8bcc1bf7eea76168bda5c6b4b9d69a850597cf26f5b87a4d0f1abdbd60cafcdf3104e
DIST psutil-5.9.0.tar.gz 478322 BLAKE2B 763c8ae14ae546bed64a360047d2ce38783e9e7e939160f751c4ccc94b8e023aaa4cdca426f584e05dae8b1326333660e216d7cb3edd820e24a931dddfa5160f SHA512 b521cfce51e90fdf87ba19bf8069877e3210aede92c17460ea0b00324a36e133168e4bff550462d07ab6d93c597c6560d68954340031ff43168d54a8e5d4c4e7
+DIST psutil-5.9.1-tests-r2.patch.xz 3516 BLAKE2B 6a16d6f89fdeb06c7aa0d9d986eba84deae5f8d2bb829c2509744f954f9b274d8a70a00f94127f1880cea71f8d7e7b85097517f8516ee6ef14f17522ee9297b2 SHA512 b69efb32cd0229056ff9fbbde963f0f01f6bf1d0820f028527f464e38a9bd4211a55bd725cc8962a20608c12c28edb24b2063f5f58b53fdb6b001fe2f95da103
+DIST psutil-5.9.1.tar.gz 479090 BLAKE2B 88f35a9134d942fa56b5fbc79753e82245c3bfdb1f640dbf3b56815b89d872517f9ee3a3945532ebd1a399c3307e160ac80394766c3b2cc7e3fb36ffdd555eef SHA512 1ddb119a10243d17d808417817ec8659d22447f12a4bbc0366c13f6587a4b0b59f4e74f6ac5d1e1a908bb5fd287be630466d32beabcb5008f6a19c24a1557c27
EBUILD psutil-5.9.0.ebuild 1157 BLAKE2B 10236f0cfb2e5b2f58e6c79e029edebd7e5d8e9ebc53f12b8620b6eb649db6ac7198cb0abdd18e0a17df6e3a86fe84a642ed202f09742a3b93e2f91e29f73297 SHA512 77ff144ed2f3c70555ec8c92b6feb73350a8ee97e96b1e92719a7847a4fd3014b26df9cc608813f45b63e0e4ef5ad3ea091774fb2e753522ec01a7c6a588b950
+EBUILD psutil-5.9.1.ebuild 1243 BLAKE2B 593488caca3f7ea620c813a4a87d85cec302d0c4a722722150507c39caf386ced35e56e54b0f28c913a7c10dd457dab598449579710daf9604d47eeec27472a2 SHA512 b7502bf413428481a6afda607fb56ea85b7f0d07f8d180b3978e98860a15747f437dba5bb734d3a7c204687de4623b5a035866b90f66bf0323cf3a83ecdf269f
MISC metadata.xml 378 BLAKE2B 235c056a427ab18383c401143074ec62b91d471087c34e2bd48d5192c6221e089e32170d18cd0d69d51eb2bb02fb8a0efe59245af9224b284557812b32c341b5 SHA512 96492308dac753fb176e4810efa71757e66413d16589e52a942b02c91256b48f9873b53a698006923aef12aa7d1539d6fd7aa07632c073b6a92cc8920f6ce6c0
diff --git a/dev-python/psutil/psutil-5.9.1.ebuild b/dev-python/psutil/psutil-5.9.1.ebuild
new file mode 100644
index 000000000000..1345a4d6ded7
--- /dev/null
+++ b/dev-python/psutil/psutil-5.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+TEST_PATCH=psutil-5.9.1-tests-r2.patch
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~mgorny/dist/${TEST_PATCH}.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${WORKDIR}/${TEST_PATCH}"
+)
+
+python_test() {
+ # Since we are running in an environment a bit similar to CI,
+ # let's skip the tests that are disabled for CI
+ local -x TRAVIS=1
+ local -x APPVEYOR=1
+ local -x GITHUB_ACTIONS=1
+ local -x GENTOO_TESTING=1
+ "${EPYTHON}" psutil/tests/runner.py ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_compile() {
+ # Force -j1 to avoid .o linking race conditions
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}