summaryrefslogtreecommitdiff
path: root/dev-python/protobuf-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/protobuf-python
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/Manifest3
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.19.3-r3.ebuild72
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild8
3 files changed, 79 insertions, 4 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
index ead7c93bc62d..8ee638497eba 100644
--- a/dev-python/protobuf-python/Manifest
+++ b/dev-python/protobuf-python/Manifest
@@ -1,5 +1,6 @@
AUX protobuf-python-3.19.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch 1743 BLAKE2B c21d80a6cd218068d2a910ccd12c314810bd2eb679b59f79ba8d4d694948841d0fd8a56e921fed6f347ae9235f33903d79a038e8ae8659ea65bb59dbf7d7d9ea SHA512 7822b826d62585c48acebf04083546a3ebf8f6570854da8bddac3cc40554e71eaf57e9579c314ada33cf5bd0837cae23a3ef1057e44f6234d1d4a591c8036678
DIST protobuf-3.19.3.tar.gz 5293258 BLAKE2B c05b70ffca97f7166ea6a511a36907eed125edf1ebf17f908718221d9b851be84dfb2b1b39973f2faf35f6ade630e6ba4f9e8b91b8fbc922c5db97079323ee6e SHA512 1c003e7cbc8eae6a038f46e688b401ee202ba47f502561e909df79770f6e8b7daf3dc1ccc727e31bfb5b52cd04cb4fef7d2d2a28d650c13f396872ad4aa076c6
EBUILD protobuf-python-3.19.3-r2.ebuild 1521 BLAKE2B fa114bf35d495311e22ba3c14c5ddb7786b0841f490eea785e7f9d74b3106e9163d7f257a7807f02322391d467bedac1553b677ff6f6902d72731246bf6a8c8a SHA512 c018c87e6c104d9c30fa6aa8088bf67d241580dab165b3a7da1443ee715d372a2371e76741863310e85cb225cf23f42b468b1b1c46cae3c3d60409012d9702ff
-EBUILD protobuf-python-9999.ebuild 1328 BLAKE2B ed33dc72c2a488ab9184411b77bfecdc654bd5ad455f0c615f9f02f32f05a742cdd1c2e57f4b9eb914f0c5571387ab321992aae2e7b4023488fb28f3efe8b9ea SHA512 d8b129bcc4226fc4afb1bb5242b16e5b31e5e519ce0bf786d1dd657e75eda47e7838b332017befb6da8fad59ce3d297380f6f072361a12855281b678fa92d463
+EBUILD protobuf-python-3.19.3-r3.ebuild 1602 BLAKE2B 870b7d110f87b88a3b9d199d4c8abc5f61ee49b5a2f6d3c6d597c7d834b59a6636b5f603d99e534fa6f3b13c7912b43d65e77617ba5890479487dcd988461b43 SHA512 9ea579677fb722ec97a710b0daaf2ac1b2a9d55044a0a966893d41c2ff80d20daf7dbb498ee32aae1341525db4de894bde95d74b813e719c47ce0cd579317b41
+EBUILD protobuf-python-9999.ebuild 1403 BLAKE2B a3212b6bd2f93ae71951e9ec8978394e660423d83cf937a3703e10ab6dfde0ebf2d5676b981c96d9dba5477a0d862b66a69cdde2ab3275134f12fc925301d1ee SHA512 6cf1111e3d591acd3642ee225d448e7887549e0a396cd94b3edd76b368a35b28b1d25ae5a946998c087309117890810b9ede95d6a170ad9926d8948d9819fc74
MISC metadata.xml 548 BLAKE2B 2468487e12d536d67daebf5b7a21cd63a9c4af321a8979132e63d9b8394bf577e347f891326c73bfa6907e82ca355ea0d4ec40a37bb297db0da1e55a62b6ef33 SHA512 c0c2556fbf8821f3a75ed344daa59b4fc355029f96efb8f9784f54c819916adeb46b2c5d8c2e8d405dc58395c2f18b30cda69c6d406948a066bd1d78a55df80b
diff --git a/dev-python/protobuf-python/protobuf-python-3.19.3-r3.ebuild b/dev-python/protobuf-python/protobuf-python-3.19.3-r3.ebuild
new file mode 100644
index 000000000000..f486c2f2c58c
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-3.19.3-r3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2008-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
+ EGIT_SUBMODULES=()
+fi
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="
+ https://developers.google.com/protocol-buffers/
+ https://github.com/protocolbuffers/protobuf/
+ https://pypi.org/project/protobuf/
+"
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="
+ https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz
+ -> protobuf-${PV}.tar.gz
+ "
+fi
+S="${WORKDIR}/protobuf-${PV}/python"
+
+LICENSE="BSD"
+SLOT="0/30"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+"
+RDEPEND="
+ ${BDEPEND}
+ !dev-python/namespace-google
+"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
+fi
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
+ eapply "${FILESDIR}/${PN}-3.19.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ DISTUTILS_ARGS=(--cpp_implementation)
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
+}
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index 9347d6babd62..3541dfec56fd 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -18,6 +19,7 @@ DESCRIPTION="Google's Protocol Buffers - Python bindings"
HOMEPAGE="
https://developers.google.com/protocol-buffers/
https://github.com/protocolbuffers/protobuf/
+ https://pypi.org/project/protobuf/
"
if [[ "${PV}" != "9999" ]]; then
SRC_URI="
@@ -63,7 +65,7 @@ src_configure() {
DISTUTILS_ARGS=(--cpp_implementation)
}
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name "*.pth" -type f -delete || die
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
}