summaryrefslogtreecommitdiff
path: root/dev-python/proto-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-24 04:04:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-24 04:04:24 +0100
commite7daa1f959ba2c720f36a6984f588098e68b15cd (patch)
tree42ed099f2514ebda2681a4de13af60727c8a9fab /dev-python/proto-plus
parentfd93fe10d9e6c855fed8e1524b2d2d64d2085570 (diff)
gentoo auto-resync : 24:10:2024 - 04:04:24
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest2
-rw-r--r--dev-python/proto-plus/proto-plus-1.25.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 1429d858caf1..8323c3b145b3 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,3 +1,5 @@
DIST proto-plus-python-1.24.0.gh.tar.gz 100401 BLAKE2B 29094738e9c84559b8b51b078ecb059e7475c5c6e9392f23925c6df264efebd22c191c5b593fc659aabb20ce9cb0d93cde9df28b0b40aac4bbc80e075a95ec24 SHA512 3995df0a7df60a9a5c9325c29456f73d8482ae3d765f9553e5633b8d0ae0869c6fe3cd60e780f8fcd49d04470205abf621bc56c20d64252b76d51c19ff283372
+DIST proto-plus-python-1.25.0.gh.tar.gz 101442 BLAKE2B a98b5131f4e55473eadb09ec9a692ef7d53312ae8f4c925ab0c5ffada25c3c3b154738c766a4e41e753c3b292c93faee54e6d7f8800c7a0af6665e4e341086ce SHA512 449fb9fe2950cff98d05fc86b4f35fab4a1b4f7c27a3b9174dbb1f6aac92484088f44c9fda4109c3f693d890606505808d7a489412be2d091e9962363c57be4e
EBUILD proto-plus-1.24.0-r1.ebuild 959 BLAKE2B eababfb0ca6e48b06469745628aaac9d1648184c644ccb4f26c10eabce36e8f5db06b2f18b7df58718337f3ef0917e331a526a27a54bf9206ef7dcd390e378a9 SHA512 62a754a229d3171f85598a4ebfe399090611092c90be7793c315e95719dc7c0f201897275f88f8924d8c33fddb396c7b9154a9aa04619c5e220819871b57635d
+EBUILD proto-plus-1.25.0.ebuild 962 BLAKE2B d24373d63d3613ce874bdbfe420f22f772b011fc60ce160eec0e7a650596d3718294335d5c6ca888fbaec53004dd2116f6555d7fa15f7063e55d5678263a1021 SHA512 d85d9f05760a2632eac55d47c5605118e3228da4cd953b938f44747c4b923a32407809495fc0a1b9862315604fd08012adb0f08170c18012cd8b51e693f8d416
MISC metadata.xml 447 BLAKE2B d440be836b8a2823ab3beb7f76cbe7ff3f027ec512dff3f7d920eefea3f18329e1aa910ca16e006b1424cbd780f3fad80b8ccdc632c08ade651afd815369e9d0 SHA512 d64b8d2eeac9916ec2faab3b038082155e46e8c379ce06d7f554de763318539fa9040d15f90a3a95f337937c90f4b4042f51b1ea1cd11727e5fd971a0af5280c
diff --git a/dev-python/proto-plus/proto-plus-1.25.0.ebuild b/dev-python/proto-plus/proto-plus-1.25.0.ebuild
new file mode 100644
index 000000000000..a7ff53eec871
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.25.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${PN}-python-${PV}
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-6[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}