summaryrefslogtreecommitdiff
path: root/dev-python/proto-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/proto-plus
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest3
-rw-r--r--dev-python/proto-plus/metadata.xml13
-rw-r--r--dev-python/proto-plus/proto-plus-1.19.2.ebuild34
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
new file mode 100644
index 000000000000..1fdb75c1bee4
--- /dev/null
+++ b/dev-python/proto-plus/Manifest
@@ -0,0 +1,3 @@
+DIST proto-plus-1.19.2.gh.tar.gz 61183 BLAKE2B 8c1c0a70ae573fc8c64004e4bd923f403bf82dbb3f9aef19239770fcd316e513ba11e6e47c56bda65c88e476072f0d90af02c83eb0fe8a4045cf3ceeccca3fc7 SHA512 c3cfb1b6aabeb4eab7f6c2c16551c1f9fbf29dc3199b496bc4b47b4b80cbe4684e5c97abe26fa4c1afd03c844a2e8f006f16c24932d2a7cf8190452943c2fad0
+EBUILD proto-plus-1.19.2.ebuild 796 BLAKE2B febdcd4febceb93400eceaa862b7142656ca78c33bce0fe616de0e6a285da6fb046bc04dcbb765a6dac56871d1863fe48e42c07d9cb4c9354cea0fcafa0492d6 SHA512 f6945c6740a07b2fd687cd7d11829395b715ef7093a78a39e80863acbb4b7e36cbdc8b42a6cb2f1cd880870f8645f0b972a6011d3e26d35a35970db2c53915cf
+MISC metadata.xml 447 BLAKE2B d440be836b8a2823ab3beb7f76cbe7ff3f027ec512dff3f7d920eefea3f18329e1aa910ca16e006b1424cbd780f3fad80b8ccdc632c08ade651afd815369e9d0 SHA512 d64b8d2eeac9916ec2faab3b038082155e46e8c379ce06d7f554de763318539fa9040d15f90a3a95f337937c90f4b4042f51b1ea1cd11727e5fd971a0af5280c
diff --git a/dev-python/proto-plus/metadata.xml b/dev-python/proto-plus/metadata.xml
new file mode 100644
index 000000000000..8ccb394b4380
--- /dev/null
+++ b/dev-python/proto-plus/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">googleapis/proto-plus-python</remote-id>
+ <remote-id type="pypi">proto-plus</remote-id>
+ <doc>https://proto-plus-python.readthedocs.io/en/latest/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/proto-plus/proto-plus-1.19.2.ebuild b/dev-python/proto-plus/proto-plus-1.19.2.ebuild
new file mode 100644
index 000000000000..762787eae60d
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.19.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="https://pypi.org/project/proto-plus/ https://github.com/googleapis/proto-plus-python"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme