summaryrefslogtreecommitdiff
path: root/dev-python/propcache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
commit4c5bd80830992553e02f099442277e10ee97372d (patch)
treebeeb8ff1f9d6f5b48418cc2134cec247aaade4e4 /dev-python/propcache
parentdb653baf275126269bb89ea0d2bdb8e50497a94c (diff)
gentoo auto-resync : 22:02:2025 - 00:16:22
Diffstat (limited to 'dev-python/propcache')
-rw-r--r--dev-python/propcache/Manifest2
-rw-r--r--dev-python/propcache/propcache-0.3.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/propcache/Manifest b/dev-python/propcache/Manifest
index b377967b2bb2..2de8069e0530 100644
--- a/dev-python/propcache/Manifest
+++ b/dev-python/propcache/Manifest
@@ -1,5 +1,7 @@
DIST propcache-0.2.0.tar.gz 40951 BLAKE2B f3e6aed19e6dfd21c02e769a3fa3c5bb0042f0b46d3dbe71ac06d52a49cfc86c62770ed8589fed58872016b5f50905610de50e707051871b9c30930e262d9d0c SHA512 f99838627652ab13919d7f516530a91565a737fc411d728cad1492ce0ed44f25b0cefbdb6fa49b2ef516e7fee120e7c49686b6853691c5cd02f5f7db9a15d998
DIST propcache-0.2.1.tar.gz 41735 BLAKE2B 9353846b481449f732751ce1bf419bf1d171b3e8fa5b4755637bab063677bfe8845da48c2cfc979936cd1af2ef559b6eb82368f9b9616b3b90a955f0b5bbeed7 SHA512 ce54baa27a9f4cec14d6db139721cb1af920e585153f541b6a192a22d805766b7a0248514fed9889d7073a611d05896fee6da1df526f2314206eca48942b860d
+DIST propcache-0.3.0.tar.gz 42722 BLAKE2B 2687c2f03464b0e81c1d3e93a0b8a11364e4b03f5614de44ea89ca401867531079c1456cc97831f9c8e885dbacca8c9dbeb30e0a31b121a2aaa3666b0397ddf0 SHA512 258e2e9e6fff5c3af62d21d0afc43026e87b8c94009db9534f8beff6d81873ab05ea626c36e43ab1ee16dea1b18dde2ec732b78b93cac82cb9c1d0438e544b42
EBUILD propcache-0.2.0.ebuild 1109 BLAKE2B 81a7b53537be9f49f69d39a698bbb0fc45819f4887acca4e695374ffd733dd3bd957f3ca5df03850013da65529d8fb22d50d1162ef9705d08c879ac71b891c95 SHA512 bde0328711f52513bf0183ec3fd0d6c5e3fbc0d0d11e33b7406bf4a0cd5f25cb9595c118e16f25bfa3c22608e3698f6e057d323999bc3bc885d5bc1f08ba883c
EBUILD propcache-0.2.1.ebuild 1174 BLAKE2B bea09182e77e1d0b061a1f86d970c1f242dbb13bd8d65617b6aabf56ac42afa18d9c3f3f996fb79a1a1c8bce450b4c7ddd07254ab55430bacad9c3f89cfdf214 SHA512 25e65be8bfce7a21fd0c207e858cb915d668f7d5ea879a926c08edc3a5e5b387a8cb096f26820bb2f8e8f6277a91696ee819f449af6ae5b8f6ff8d23694ce4f4
+EBUILD propcache-0.3.0.ebuild 1181 BLAKE2B 78c8fcc9651b467a1970c93effe531a72997333c1f6d6fe049c87392baf8bbad4b236377191ce98953896048a1f3aa950747196663cd68339031098d3d4b72a3 SHA512 e5163aa7e2f37cd50fe9382b54d3d05efe058e3e2742893b3c7ca8498a7293340a3d7dcad01a794c2c8013aa6e891d4347819e1ad9721d83427c9a78a9359c35
MISC metadata.xml 371 BLAKE2B 2aae9561b0b663dbdf1935d4417af8fdba00636b23ec09037bd14d0ab3bdbf6ff4b093a5ca901b50046134b6b4f25d72a09b544ca949663688d9e1c64ae49a4e SHA512 b4e36caa49357be56c1d07d75c29a30dd18c0cdf1e7e6edfd347748a3edc084743b2163f60e94b837477ffc6320e6140a721769a42d224d3963cc91a18d492bf
diff --git a/dev-python/propcache/propcache-0.3.0.ebuild b/dev-python/propcache/propcache-0.3.0.ebuild
new file mode 100644
index 000000000000..f9aebdde55ee
--- /dev/null
+++ b/dev-python/propcache/propcache-0.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/propcache/
+ https://pypi.org/project/propcache/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+ dev-python/expandvars[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local -x PROPCACHE_NO_EXTENSIONS=0
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ PROPCACHE_NO_EXTENSIONS=1
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_benchmarks.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local opts=()
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ opts+=( --no-c-extensions )
+ fi
+
+ rm -rf propcache || die
+ epytest -o addopts= "${opts[@]}"
+}