summaryrefslogtreecommitdiff
path: root/dev-python/prompt_toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/prompt_toolkit
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest2
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.26.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 5e88dd12d853..cd410a124f99 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1,3 +1,5 @@
DIST prompt_toolkit-3.0.24.tar.gz 3042044 BLAKE2B e9b4186a38756cf6c0d92575e42dfe4507e63f721038374252e7a7d5af76f7df04dc01251079d99a74167aef7e394b50c43b5190df8b9cd68cf74eae31dfbe51 SHA512 e423735441407ffe51d46225efa4b747899d47fa5d5a2163e5c0c906d2f1937e80a67bcd06ff6aa97d8a336e507fd0322957e79b9382d1a678994060fcccfb84
+DIST prompt_toolkit-3.0.26.tar.gz 402667 BLAKE2B 60160c3e0059b570321d182699b2e6cc10e7d771e9c328314e5561329aec5ddb4951d5cd50d49414314d50a9542e223b44e9c589d272ccf32bfb4f54ed1a9980 SHA512 7151d6678409bf3b04bee76cbcf4e0ffb5ca1963c359d30c8edf9e81bde424ea69b7009cd44e6d72088936290e2fd9dd8cac59efc8b5e59bfb87dacf53967b05
EBUILD prompt_toolkit-3.0.24.ebuild 619 BLAKE2B a3cef7f646a102e2eecff28329f358af27914367e6d8b134a138270239a980685e08c35f0c0653e8e6a5cce988575d4fdc8e1fe0913ad5130cfb8083282e6f92 SHA512 6bacb686b7535ed549294cb7aadf69107f634787a958e24618327bda188ebe4f381a3c8c21d6b50ef89892de9c7ef63b3a2d7d0e9b0adef4da678e38bc7c8724
+EBUILD prompt_toolkit-3.0.26.ebuild 620 BLAKE2B 6d7475f290cea9555c3d2879e078ae8afd42bb62faa2676b3345369581decff53508578cc62efcf03b45a38c1e65304200b9a60413a8201704ada0f15d64e7e9 SHA512 32998dd61796e8761904b8e3abaf8f2fa4a99c0a3ac399eb9f3d06d878213019c8d4bbc6a45ae670b6eba331575aa4114fad509f9dd61531d11979b6602f5092
MISC metadata.xml 431 BLAKE2B 534336484c65b57df5e672729ff722b67445948e0485c3a62c2f7081724cb951b5157c600dc6162a3bb857c2be0f378b18670786279ff8b5cff2858588f8ebc9 SHA512 a9bf68326839069c61e70d4ef3fe304706f2543b9b91eb291566dd66f36d1abec00382ae205549a35f10dfc730f4613c5cc5c0ee4d6858538d50c4145bd3b15e
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.26.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.26.ebuild
new file mode 100644
index 000000000000..2f2c6d382cf1
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.26.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest