summaryrefslogtreecommitdiff
path: root/dev-python/prompt_toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/prompt_toolkit
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest2
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 18ba6e41f10b..a52d099f6c1a 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1,3 +1,5 @@
DIST prompt_toolkit-3.0.28.tar.gz 3057388 BLAKE2B 87e5723f0c28a60e0241d051746c3e1124cb0e95bfcfead5da3594b89da3e190a139c0fda2597b3c435e3c3cae9bde8e75c16745faaad624d7c10c698eeb2c95 SHA512 143771bbb96ca761ba1e47dbe22b532081f39a6769935d90e320217f8566b15be5407aba5e7ff48d9e3e71782c9c9604536b0284c6e322179101adecbedd5ee5
+DIST prompt_toolkit-3.0.29.tar.gz 417831 BLAKE2B f46ff507c991f6bf9536f0161cc79734013c53dddd9053076a8da7532233138fd179c6adb009af575329b3a78ab5bf6ef34e3d8eba1f5cf80cca951a32cfcc04 SHA512 a0d1562fe4ced52972ca7ee3bc9fe158865461b28be393436651f326cf2ddf0553d49ac8051ed700ef95d3ce2a76b9fcc10d92b6890203aca4e27e050cb814c0
EBUILD prompt_toolkit-3.0.28.ebuild 620 BLAKE2B 196ebaa518a101177bfb21a23009c4f66373bbf3afafe7e3bae37284d9f4564b7335ea30991d604d58f97eb16c0c517bb68ba64461354ee37847727c76554eef SHA512 f28f390e9c893e0b5e0a6ae9ae04f674a2f473d22c16a8f9929ca526fc49f55b99b754ad7a17bfe5286ea8dd35bdabd129fa4d604452ec3f45ab179e014d1c25
+EBUILD prompt_toolkit-3.0.29.ebuild 632 BLAKE2B c3f562e980e285d304e959c71daeb78aed088c1a7c56708ddf14e1952ea310cc1c34a18872f22898249c4e375151d98d9119852c31ce4539d2ff942750396d1e SHA512 06853f9a25d50f98f7177cd571433989ebce7b5366a1643dd755a086623f73aa0325f6b007c75430f3c6e45302b168976ec6d4809474acb41167e2ec0f22cfe6
MISC metadata.xml 431 BLAKE2B 534336484c65b57df5e672729ff722b67445948e0485c3a62c2f7081724cb951b5157c600dc6162a3bb857c2be0f378b18670786279ff8b5cff2858588f8ebc9 SHA512 a9bf68326839069c61e70d4ef3fe304706f2543b9b91eb291566dd66f36d1abec00382ae205549a35f10dfc730f4613c5cc5c0ee4d6858538d50c4145bd3b15e
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild
new file mode 100644
index 000000000000..f768088b0976
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest