summaryrefslogtreecommitdiff
path: root/dev-python/prompt_toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/prompt_toolkit
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest4
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild2
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.30.ebuild26
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 64c8ac846cf5..05b09db66388 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1,3 +1,5 @@
DIST prompt_toolkit-3.0.29.tar.gz 417831 BLAKE2B f46ff507c991f6bf9536f0161cc79734013c53dddd9053076a8da7532233138fd179c6adb009af575329b3a78ab5bf6ef34e3d8eba1f5cf80cca951a32cfcc04 SHA512 a0d1562fe4ced52972ca7ee3bc9fe158865461b28be393436651f326cf2ddf0553d49ac8051ed700ef95d3ce2a76b9fcc10d92b6890203aca4e27e050cb814c0
-EBUILD prompt_toolkit-3.0.29.ebuild 624 BLAKE2B 71e3e0ef66e87ddb180ac72aa4c91a71799f022bcb0281ad492667ed0626f1d786146050e82648f0120f36b4df8b8a614a4d6ec4ab0403211c9c58f8deeb98b2 SHA512 8ed1228d59ceb367d94f5a5f7aa2f4f02315b95c5780946ce61f197e97f192dcaac2797a0db6b2d5a2c3f8bd42eab37001156a4443218104ba840e98fa35cad5
+DIST prompt_toolkit-3.0.30.tar.gz 418985 BLAKE2B 2edc5024e22ccf60ab68afef9958eead5711b88f4f2abfde387e626893778eda5203f855a5590776b25efb3fccea87012d01e39551d192861841dab188d149e8 SHA512 cb0b9d71b09c353f2674052d75ec16a1803e0868ff5dd5625eefae767d45699b1b6bb99e4d98d3bca7ced7b60f52806ec10ed7ccab8a830c62d51baeeace23f7
+EBUILD prompt_toolkit-3.0.29.ebuild 624 BLAKE2B 55f6792522d0e9060e8450a4a746773f224fd920d63330ab4f1a926ec1f2f84384451d9602819dcf16f95924aef7987aec9fdcb619e937d5038c627d76f30e38 SHA512 29e465000f016239bddbca6ac3c9f880ccc670f812d3a9c58ff8b1e17d288bf61464a2d23c33331f472e66ba870a7adb87c7f4be01d11de4d8040374b8f73141
+EBUILD prompt_toolkit-3.0.30.ebuild 632 BLAKE2B 39797963edd09eb2b760df5a940bded40aeb978dad95643bff7c25e9ba2652ac0454c7abcda5ee6b7acb09403b90ade888273d78474eba3d2170ee8d45924920 SHA512 20f369e8817ca6228878e0663d44f4f127c29e49caca1fda69242a156f91dd3498502fa6a1cc5bf99664b04de135977ec71c605cb2dbac0c926a713311cd0da2
MISC metadata.xml 431 BLAKE2B 534336484c65b57df5e672729ff722b67445948e0485c3a62c2f7081724cb951b5157c600dc6162a3bb857c2be0f378b18670786279ff8b5cff2858588f8ebc9 SHA512 a9bf68326839069c61e70d4ef3fe304706f2543b9b91eb291566dd66f36d1abec00382ae205549a35f10dfc730f4613c5cc5c0ee4d6858538d50c4145bd3b15e
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild
index 70051e586baa..f2629af78381 100644
--- a/dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.29.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.30.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.30.ebuild
new file mode 100644
index 000000000000..daef0b2a5e76
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.30.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest