summaryrefslogtreecommitdiff
path: root/dev-python/prompt_toolkit/prompt_toolkit-3.0.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/prompt_toolkit/prompt_toolkit-3.0.20.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-3.0.20.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.20.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.20.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.20.ebuild
new file mode 100644
index 000000000000..2311603cf192
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.20.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest