summaryrefslogtreecommitdiff
path: root/dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
commitd37f8725bb68034ef10d8882fb4411a49f2f666e (patch)
tree2b530ee04815bacc1dc051db24c2727d3056b77b /dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild
parent171d09fa1f429aa43835c618a2c21753ad5209a4 (diff)
gentoo auto-resync : 21:02:2023 - 20:25:12
Diffstat (limited to 'dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild')
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild
new file mode 100644
index 000000000000..40c5d051dccb
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest