summaryrefslogtreecommitdiff
path: root/dev-python/priority
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/priority
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/priority')
-rw-r--r--dev-python/priority/Manifest2
-rw-r--r--dev-python/priority/priority-2.0.0.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/priority/Manifest b/dev-python/priority/Manifest
index 9b190dc0e6f4..faf9250e2d5e 100644
--- a/dev-python/priority/Manifest
+++ b/dev-python/priority/Manifest
@@ -1,4 +1,6 @@
AUX priority-1.3.0-test-timeout.patch 716 BLAKE2B b48691b508a4116c9656acaa3a31871e5c8a66c45d6724506590c95e09eac027969def8198c5bdaa14e50cd77ea105881b7ddb7f36c95665502799f5ea751b6d SHA512 9e809600bc972baf4e1f5366c65db5e5d050bcfd0df23da3d1f75f653a0fdc27f7e4a59e96e13bd42636360653dfdc1de1991e6684e95bfffbf0c4384d7dc550
DIST priority-1.3.0.tar.gz 13827 BLAKE2B 8c100eb44ed42f4f624bfb37dd6f698a3da84812783bd44ba82afef565562379a7677b3cbc9e16c4ea5a5dcc91d0897fa47c341a81bc1875461a72aff328fcff SHA512 cefb13b15e99ef98c37fdd1486466c9e1d7d04b4574cbca1665fde7b7b44cc7d66964bed41184315a9b51bd6f9d0e02bbe113bfa004a754ac270170309b71e0a
+DIST priority-2.0.0.tar.gz 24792 BLAKE2B c230f74aba3153edafba4bf85965a726ac3d3f5e2293d7c496b65fda260722cc44e4582666eee9d715e0d0686695434f8e0cbbd089c105bb45b777bf6eb4d72c SHA512 f90648a3ff1ee4131f30e99ecd8c36110abf484733f507edefcede8fdcb9ec3a618b9278e85724855709f41facee438061e4c5cae201b6e916c22f4a451db575
EBUILD priority-1.3.0.ebuild 699 BLAKE2B 1c7cceec979ef8c857192b266b7470a5f60eede6da8cc232f6243e21ffb8387a3628f7eaa28fda944239458a59eccc92c8b4bfd9e3edf32f41717a353f7ac423 SHA512 d124b956e3f493146ceaab4b5c80ebaf83d19e94a24b3577bd90cb31fcdbc0e4519f579d8002e5eba21d48326272380f88f3e457bd5a1883cd395960b0f08906
+EBUILD priority-2.0.0.ebuild 645 BLAKE2B 40ed94bb8d68685f84f739b3e8bb49cabd3a7fe441a52d3105131c341393ddcab10340e028f8588317aabeec543958786bde6a41e85eadd09513a44acedaed5f SHA512 cb1db5a3be022caabb92fe8bca84c7a7edeab87fcd6ecbf6cc9679a055bba743de43ca1a296fb558b3eca839bd9c8919f90255d09c82efbf246cfadb1fc16a9f
MISC metadata.xml 839 BLAKE2B 2a922ade07ccabbde2eaaeaac310e1c89206f7a6194ea14cd83f53182270edfd2cca4b1d13072d8a4c81c96563ba3b81251626eb777ced188bc9a22a37dcbffb SHA512 fbd62fe6b97e29566a18a29d155b8b08124d5c1561a21ad7aef7daac1a68b75b48b82d3edc612a27888da0d24ecde73b808cb90dfb7fe78ee97adc5fb507b003
diff --git a/dev-python/priority/priority-2.0.0.ebuild b/dev-python/priority/priority-2.0.0.ebuild
new file mode 100644
index 000000000000..ddf8d8fde3dd
--- /dev/null
+++ b/dev-python/priority/priority-2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
+HOMEPAGE="https://python-hyper.org/priority/en/latest/
+ https://github.com/python-hyper/priority
+ https://pypi.org/project/priority/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest