summaryrefslogtreecommitdiff
path: root/dev-python/priority
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/priority
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/priority')
-rw-r--r--dev-python/priority/Manifest3
-rw-r--r--dev-python/priority/metadata.xml25
-rw-r--r--dev-python/priority/priority-1.3.0.ebuild35
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/priority/Manifest b/dev-python/priority/Manifest
new file mode 100644
index 000000000000..d98e28a1853e
--- /dev/null
+++ b/dev-python/priority/Manifest
@@ -0,0 +1,3 @@
+DIST priority-1.3.0.tar.gz 13827 BLAKE2B 8c100eb44ed42f4f624bfb37dd6f698a3da84812783bd44ba82afef565562379a7677b3cbc9e16c4ea5a5dcc91d0897fa47c341a81bc1875461a72aff328fcff SHA512 cefb13b15e99ef98c37fdd1486466c9e1d7d04b4574cbca1665fde7b7b44cc7d66964bed41184315a9b51bd6f9d0e02bbe113bfa004a754ac270170309b71e0a
+EBUILD priority-1.3.0.ebuild 955 BLAKE2B 8b9be21d00c4630abfb5357586453b865519909c3145152f61aa4c964d7ffe097f89e36850385a91ffc242cc0340a38636a78de3f3db07aa93f6790522c14201 SHA512 9b45ee55b881f212c2ab67ce3d34b080ce5eaef253f080ee31205be90dbbbc90e9c9d62c9ba6916dcb5a9bdccc37a605df99fb93cf2f6da110201ae46fb578e5
+MISC metadata.xml 917 BLAKE2B c92ee27c2cdaadab26b9d68451c0b7ee055e26ba9457e5fa8dcbf2f9b4add141d07e85344d7de536db6a4a40da92d79c67862da2bb381f0bf1b384f90565f2a8 SHA512 e5daf360e9d2c4efeae4084d9a72ac975acc09f95d0064f4d2c3759ba00a080ea5a2f689f74ce666633fae26d1afa095f29b209912fcae0ba38d9fc1231b74e0
diff --git a/dev-python/priority/metadata.xml b/dev-python/priority/metadata.xml
new file mode 100644
index 000000000000..a610eaa8f96b
--- /dev/null
+++ b/dev-python/priority/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>cory@lukasa.co.uk</email>
+ <name>Cory Benfield</name>
+ </maintainer>
+ <remote-id type="pypi">priority</remote-id>
+ <remote-id type="github">python-hyper/priority</remote-id>
+ </upstream>
+ <longdescription>Priority is a pure-Python implementation of the priority
+ logic for HTTP/2, set out in RFC 7540 Section 5.3 (Stream Priority).
+ This logic allows for clients to express a preference for how the
+ server allocates its (limited) resources to the many outstanding HTTP
+ requests that may be running over a single HTTP/2 connection.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/priority/priority-1.3.0.ebuild b/dev-python/priority/priority-1.3.0.ebuild
new file mode 100644
index 000000000000..39cb4d69564a
--- /dev/null
+++ b/dev-python/priority/priority-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
+HOMEPAGE="https://python-hyper.org/priority/en/latest/
+ https://github.com/python-hyper/priority
+ https://pypi.org/project/priority/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" py.test -v || die "Tests failed under ${EPYTHON}"
+ cd test
+}