summaryrefslogtreecommitdiff
path: root/dev-python/priority
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/priority
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/priority')
-rw-r--r--dev-python/priority/Manifest3
-rw-r--r--dev-python/priority/priority-1.3.0-r1.ebuild31
-rw-r--r--dev-python/priority/priority-2.0.0-r1.ebuild8
3 files changed, 38 insertions, 4 deletions
diff --git a/dev-python/priority/Manifest b/dev-python/priority/Manifest
index 6eca89269932..9e65793e5a5a 100644
--- a/dev-python/priority/Manifest
+++ b/dev-python/priority/Manifest
@@ -1,6 +1,7 @@
AUX priority-1.3.0-test-timeout.patch 716 BLAKE2B b48691b508a4116c9656acaa3a31871e5c8a66c45d6724506590c95e09eac027969def8198c5bdaa14e50cd77ea105881b7ddb7f36c95665502799f5ea751b6d SHA512 9e809600bc972baf4e1f5366c65db5e5d050bcfd0df23da3d1f75f653a0fdc27f7e4a59e96e13bd42636360653dfdc1de1991e6684e95bfffbf0c4384d7dc550
DIST priority-1.3.0.tar.gz 13827 BLAKE2B 8c100eb44ed42f4f624bfb37dd6f698a3da84812783bd44ba82afef565562379a7677b3cbc9e16c4ea5a5dcc91d0897fa47c341a81bc1875461a72aff328fcff SHA512 cefb13b15e99ef98c37fdd1486466c9e1d7d04b4574cbca1665fde7b7b44cc7d66964bed41184315a9b51bd6f9d0e02bbe113bfa004a754ac270170309b71e0a
DIST priority-2.0.0.tar.gz 24792 BLAKE2B c230f74aba3153edafba4bf85965a726ac3d3f5e2293d7c496b65fda260722cc44e4582666eee9d715e0d0686695434f8e0cbbd089c105bb45b777bf6eb4d72c SHA512 f90648a3ff1ee4131f30e99ecd8c36110abf484733f507edefcede8fdcb9ec3a618b9278e85724855709f41facee438061e4c5cae201b6e916c22f4a451db575
+EBUILD priority-1.3.0-r1.ebuild 771 BLAKE2B 03f1e1e7622b96eee80e37a991ad03b622a2a00e61bfc82eaf79ef7f04dcac7d5e436a0abe05f4ebc18654c28453d9caca6b0fdc6f873cdb6e8782092c3ca357 SHA512 50e3ae2d7604c32d36f81d6c31c8614a81b778782503f808eb64f3545af6419d7428d2deb85bad4f736f80b49eef62ce832e72c5348dd75e8545f5f78dce9fe6
EBUILD priority-1.3.0.ebuild 718 BLAKE2B 31df88a983cca618ab29ea6e17efc147a7e3c9b76e4648e3070e58ee0ebc71ab99848090b2f5640ef73e79fee515164f82c15bf4fed3a336d045c141b8cd5d72 SHA512 f0e97a067ebb736e5a50e840ab39618455730cda04991a31f9cc1905f55753635ccc5daf1e2738c654d557ef751ad16580910b531d39115dec6ab83bb3c31ea0
-EBUILD priority-2.0.0-r1.ebuild 698 BLAKE2B fa99bc11ed459459fb64186fc45f6c6c2838bf642c1f9c75f95e9aa41f0fc610911c9eec070a1506bbd801de807f231e36a92b290feec4bcdca9223a53d68be3 SHA512 eaa477f041a7c9e747bac94bdbba68cb7e97e3fc0a6d7de3b0435e55a39c43e4f340cef2437a1095369365a76bb8486adcc3ae94bfe34850fe614fd58828d546
+EBUILD priority-2.0.0-r1.ebuild 701 BLAKE2B 4f965add99cf3b4e05740b8e4658900897c19147e8103ebb908c144b6859a8fd65efc5639a18c30a409764229f4d9b1d87999254e9a7808a8b5fbe46a0d98978 SHA512 410e923e0e0bfbf4c4fa3b9e38d2b762068b8e997462d587f701bd7f227e3c2779092de77b58ce199b70de3b3401bd6eb54ccd9af5fbaba810859a2cb72f9bb8
MISC metadata.xml 840 BLAKE2B f06ec0d98208bec42462213928f2f312649ff7765747b591e4ec0b68fecbc3666c0a99d328c11d0f0e8a086b2e82dc76a9f82503a6e70a2346c802f9026cc692 SHA512 cf9161bb9d3c488dbec74364385022a067b9911caa9bfc2499c00e49342303ffea899e67eb5dffc8fc5a4285209eb4806db2c28d16f91e8407879101a2d324fd
diff --git a/dev-python/priority/priority-1.3.0-r1.ebuild b/dev-python/priority/priority-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..7d55561bc434
--- /dev/null
+++ b/dev-python/priority/priority-1.3.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
+HOMEPAGE="
+ https://python-hyper.org/projects/priority/en/latest/
+ https://github.com/python-hyper/priority/
+ https://pypi.org/project/priority/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/priority-1.3.0-test-timeout.patch
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/priority/priority-2.0.0-r1.ebuild b/dev-python/priority/priority-2.0.0-r1.ebuild
index e18fa7a80fef..959444a9f5e0 100644
--- a/dev-python/priority/priority-2.0.0-r1.ebuild
+++ b/dev-python/priority/priority-2.0.0-r1.ebuild
@@ -4,14 +4,16 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
-HOMEPAGE="https://python-hyper.org/projects/priority/en/latest/
+HOMEPAGE="
+ https://python-hyper.org/projects/priority/en/latest/
https://github.com/python-hyper/priority/
- https://pypi.org/project/priority/"
+ https://pypi.org/project/priority/
+"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"