summaryrefslogtreecommitdiff
path: root/dev-python/prettytable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/prettytable
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest2
-rw-r--r--dev-python/prettytable/prettytable-2.1.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 837ad4259a31..c6ecebc120ca 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,5 +1,7 @@
DIST prettytable-0.7.2.tar.bz2 21755 BLAKE2B 385d5bd6d4ab75a8c7ae96abc9d9e98a66a196265853113e7fb59073876e9f5e9c6c4fba9a30d80cc726a5184e78fb6451ff9a553909704fcc5022b6a08413f4 SHA512 f3a3fe6fa29f4ef090ff6cac06549ebd9db8b387e7b25fc64c4e37c8444586f50355c5573f38caabc72360aa68054aa189a67aa37f0bd13b872862ecd9151e71
DIST prettytable-2.0.0.tar.gz 43072 BLAKE2B 2293d0377f0bbef925014812cf0cd3702ef4f651927302012df44e829dd9ea249d03ddaee32f9313f3d001900e92df9a3be8812c8fc573624d308fa5c40a858a SHA512 b7c47df7d85a91e9518dea8dafcb27037e5cde81f59dd2b9e9468ae44b18431dd7d943fed487d5713e2c5aa25df76a8eb6587d045f73b8f25f53715a8a2085fc
+DIST prettytable-2.1.0.tar.gz 43306 BLAKE2B e2085003f2720d573e19fb2b03c8aa98262ec9e7a3f7d0a20474cad2fab374a91664bb513d8158cd612e58a47917c3ebe8b43798272f38c182f6cc2472918f55 SHA512 8eaad22c66299ca3f66cc167e1a94aa41e3b2699da4ff48a0e81927ee8cc623d3147ae29a0bef92370d07d6a7fb6b1eac535fca7090562419aed219b9483edd5
EBUILD prettytable-0.7.2-r1.ebuild 599 BLAKE2B 81279c0a0b31c8d20b3320531e78a9503d493c7432b758873826823c35e9db0e8e1069d1cc551c06ef5a223732a74bc4585247ba4a1973c03a5738e7cb6ebe3e SHA512 c05622c9ff27784044c47dd092a34545e464daf0ab17fc0b0e6e2eaa957a49e1b0612dd4fb87b907a4ccea023a8b0c383f65a8c1f98fc466cb55deefe66c4700
EBUILD prettytable-2.0.0.ebuild 834 BLAKE2B 67567c319ede6e5e5cac3f5165405948d9501af776b164e480c2ff60ab63c946fc0282f2d35d17b6e388aa54c7e97773c048a9b06a7a98646b46d75ed65ad7c5 SHA512 553da775662dd6c1a2029545384bddde6add78dff92d30823dcd8215f1a0ff6245de26f44b65f1f9e9489d38ee159efa26958711040ce25b7d71b46407ca5036
+EBUILD prettytable-2.1.0.ebuild 716 BLAKE2B 2d5d3c5a66fb4eb184bb39749569a77a96b60905b6f5fc58a31d691cff516d4f1ad80622007d42f66f2a99f0948c545607a0bfe4635a7cbde49fd8c26312c7b3 SHA512 50c1067d1b2f8c228afae4710887d9cd2444a4beeaae74f18ce0d2e7679c2f2bb08924a29f91040ab6c27eb84504850274d81f0b7e270ddd74709079c42157eb
MISC metadata.xml 582 BLAKE2B 2abcef37a8ef89f66a30fa5c96406bc7ae799f16cbeba3ab5105d5412da65ecdc691d410b0d4147d089290ef49a0fd8c4af42c1676c7161d82b12b31f7a2d5a1 SHA512 e4665346eda726a3041e5eceff3e7925bea95dc2a2df761c7f807d9da0f333d5a46a68ffb1413e6118e40c459fd08af9e9d73e6a45e9c84d41628d80e86fca60
diff --git a/dev-python/prettytable/prettytable-2.1.0.ebuild b/dev-python/prettytable/prettytable-2.1.0.ebuild
new file mode 100644
index 000000000000..f5e4ead55000
--- /dev/null
+++ b/dev-python/prettytable/prettytable-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )"
+
+distutils_enable_tests --install pytest