summaryrefslogtreecommitdiff
path: root/dev-python/prettytable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/prettytable
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest4
-rw-r--r--dev-python/prettytable/prettytable-3.2.0.ebuild2
-rw-r--r--dev-python/prettytable/prettytable-3.3.0.ebuild31
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 599b350653b3..2c44810e0f04 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,3 +1,5 @@
DIST prettytable-3.2.0.tar.gz 52976 BLAKE2B ec41ffe9c752f530128d641a3341cc5c2dc4fd26ae8cf795fd526144ae8c82d359d022a9d52aebcea3217251c7d9513ef2df0f50c3a4f31ec0c2ef6b9c7e6189 SHA512 8f2a0945159727741a52ffdaa5602b862841cb8e0c33d3f755699f4376d2c0bfa539a270e56242503f94cb4fc469cbfd27348abfd740ec8f1cd3f1970053e5db
-EBUILD prettytable-3.2.0.ebuild 774 BLAKE2B 32e7c0837f0a81192f9f7d8c0e35dc9b9af73419406a5523cd2b0de1431de98324a90e54d560e2a4fbe6d2fdcd76fb0071cbc29d9ae0961f1e8251750dcf3282 SHA512 dc22f077cad2fdb014613769eb1f5200b7f58e470de463ad3f877f719d9b3e5f315d930fe50181ae2ac0c7d968d9bf5e0db396d77450692bbaa9654f30fc8573
+DIST prettytable-3.3.0.tar.gz 54305 BLAKE2B 4d131c16b6c6a0fd64aae1f9f54e286bf27b562888af56a6944d192a24c05d6138c3bdb8f298dcc060db7609d72b8d86ab9664bf6bcf43cd2105bdd433bae3cf SHA512 e190717e2ea89e8faddc7015fd5118e0d93ac5f5318641ce5960b22b4ea3740ff12c4d15812b33655252f258c96f9e848f554d1e678d39761c28025ba7772609
+EBUILD prettytable-3.2.0.ebuild 780 BLAKE2B 66290b1b9b3217068b906805c9fa4b786603f944f6d6a0b5af825d913baac947a6a066649a547e489636ffd6b093737cd870bae7d8cb44d1e8ea4a5622533b6c SHA512 8bbbd5b9eba073e747a1c3df13f98dc2f3851e09271d51c2da2b711129ff4ae4cf22034afc33ed792ff9cabf68fef5c3c09ca6f97a4e875ba470dc195a8fe40e
+EBUILD prettytable-3.3.0.ebuild 785 BLAKE2B 4d788476429eef1bc52b6ec08a6732378540a5bb2e5ddde0a05bae88e99720169300e29945108c8dce00fbcd7ddc494e07436dbbd61bab5d3a40f884cbce0948 SHA512 7487dc756206d08add72ca8547f8a675beb11b748594ddf41b5687b7881c89030dd3383ae7fc1fb27904a8fc5cbba76cec86e8b45ec3d1044669d35c59c22684
MISC metadata.xml 583 BLAKE2B b82fa13dd76ee47e012c03499081072c737cb63f2d23190dc3622dae1bc50ba054c7cf492a1feda7147c3a8710bd8ad509bc653e5b40f89b93ffd63da69c3f65 SHA512 e7d331df0ec72f98acc9abfc70424a619e67e559e4b02b357658e9e48efd080440a0d890ce5df2cb8cbffc53640b2068f39f803aa180bf2607d02a9df1acb5b3
diff --git a/dev-python/prettytable/prettytable-3.2.0.ebuild b/dev-python/prettytable/prettytable-3.2.0.ebuild
index b1fb8aed347a..5ce1f0f06343 100644
--- a/dev-python/prettytable/prettytable-3.2.0.ebuild
+++ b/dev-python/prettytable/prettytable-3.2.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc64 ~riscv sparc x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
dev-python/wcwidth[${PYTHON_USEDEP}]
diff --git a/dev-python/prettytable/prettytable-3.3.0.ebuild b/dev-python/prettytable/prettytable-3.3.0.ebuild
new file mode 100644
index 000000000000..e5850a816952
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest