summaryrefslogtreecommitdiff
path: root/dev-python/prettytable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
commitbe8708090362c01c6111c4b76f1e395c14d86e00 (patch)
treebb61ca73e867522450783849eb63c9e1f0ba1730 /dev-python/prettytable
parente93a38d535f2c29b55a5756d2de99425986b0bf3 (diff)
gentoo auto-resync : 13:08:2024 - 11:06:03HEADnextmaster
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest2
-rw-r--r--dev-python/prettytable/prettytable-3.11.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index bd2105d7c9af..794a6080a50a 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,3 +1,5 @@
DIST prettytable-3.10.2.tar.gz 56415 BLAKE2B 0deb8132124f9c19ecaeea46749dda834c758378163646e16e0553b75ad6842b44fe5904ba181d6a2b0c3a822f23cd569977a8168d9245b2e9f08ed16da0089e SHA512 6a71f7d7b6fddca75e4b1bfd96ca6e26301c0c231be4703fe9c59e1c13a1482f814fbbfd661d1fc6bb37346f55a7488b794d5041016faf68711297a8cbdbe5c5
+DIST prettytable-3.11.0.tar.gz 57527 BLAKE2B 494f3ff0802b29a419f58310a0ad50ccd1ae39845ad5167956f68ab674a2b357d098e28426c8df6a889026eaf397593018070d441cff20f0a01b76c51470a482 SHA512 3da3dcaeef1f8ce224381a6a12e56a7220e7bf7bc6a99402cd0ae68703d0630beb42f6575c86981f1ff5f592283a990398d6dd1bbdcc21074f77cab4739683b7
EBUILD prettytable-3.10.2.ebuild 731 BLAKE2B 97686d9f0b035fdf7332f88c5357e3515867f6a2c2cf50fadaf1571d59741ff6c0406d8e2e83e1ab30e4624e3e2b1c1efad2a58b6ca40e114496896155a3f1f8 SHA512 a1bc8359ff73b34117100b7b65f1b0d8adad1c7cb5661177a00c76ae65e37f7b4d0d695a6a4a41735c63027aead586a90c694d98e15d58300976b6e9fae4ba33
+EBUILD prettytable-3.11.0.ebuild 736 BLAKE2B 1a4d2044631c3268833b663b67a0a9bdc24b4e30c41a9833a1113a40788fb99160a13e7428d1c4ba180390e66f03339a7d0b41f19a4c7c490c5ff091af4755c3 SHA512 ba49fb35a2985e633b1b64e8b035a5c01c58d395000f426960cf4dda1ff361d4096f947ad636d38eb58de2246afd0300fc1caa5e9f8f4b927658d7e2120c5296
MISC metadata.xml 583 BLAKE2B b82fa13dd76ee47e012c03499081072c737cb63f2d23190dc3622dae1bc50ba054c7cf492a1feda7147c3a8710bd8ad509bc653e5b40f89b93ffd63da69c3f65 SHA512 e7d331df0ec72f98acc9abfc70424a619e67e559e4b02b357658e9e48efd080440a0d890ce5df2cb8cbffc53640b2068f39f803aa180bf2607d02a9df1acb5b3
diff --git a/dev-python/prettytable/prettytable-3.11.0.ebuild b/dev-python/prettytable/prettytable-3.11.0.ebuild
new file mode 100644
index 000000000000..21f867b499ce
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.11.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest