summaryrefslogtreecommitdiff
path: root/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild')
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild b/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
deleted file mode 100644
index f592bf0fbdac..000000000000
--- a/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_P=pyaml-${PV}
-DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
-HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_P%-*}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="WTFPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/unidecode[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- # https://github.com/mk-fg/pretty-yaml/pull/38
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-python_test() {
- "${EPYTHON}" pyaml/tests/dump.py -v ||
- die "tests failed under ${EPYTHON}"
-}