summaryrefslogtreecommitdiff
path: root/dev-python/precis-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-python/precis-i18n
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-python/precis-i18n')
-rw-r--r--dev-python/precis-i18n/Manifest3
-rw-r--r--dev-python/precis-i18n/metadata.xml21
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.0.0.ebuild28
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/Manifest b/dev-python/precis-i18n/Manifest
new file mode 100644
index 000000000000..878eedf6d6ea
--- /dev/null
+++ b/dev-python/precis-i18n/Manifest
@@ -0,0 +1,3 @@
+DIST precis_i18n-1.0.0.tar.gz 61251 BLAKE2B 3f49f77ae4e6eea6ac1429a8de9b4ebe217d4d901edc223ee487d8a11bb45dc9e21a1e9fef9bd4478273ae721b5c02e4e2a7d2a3f28da281fcbdc17a12a1094e SHA512 9017852fdd2a066b8e31521bd39843f3b1f87259ce87e1567cfaa2b932b52b745ad84eb89b77a4c3ea0a04e513573655266b2cc73997e951268646da7a000e5d
+EBUILD precis-i18n-1.0.0.ebuild 546 BLAKE2B 19a3c5e30811608d7ae61d0c5f9446e2ff77343379bc8beb9b92ba49829e058940bffc6334621c8478cea4f7f18475a7e2f1336b99a6f64b2aa11dca470bdac5 SHA512 018bce20111d3963c23cf2792b779e54928e1e4581f858a09ecf19d287b25052e9f95e3a1056a43b6ffd519e7aa8478cf0594cbfcd5581123517e4854ced5a0f
+MISC metadata.xml 945 BLAKE2B e05fc6a6170827749badef2aa323c05a7c57ceaf89c21d11d64d9b7e43623a1486c5a90ae4fa6a6d40557a19fc4a3b06eb1575a7981bfb98c46826de8297dd1c SHA512 d45d169badda2117215c9145a80e95bb03f13018631e813b61c09b84e6e860e56e48054aa874639d3111aa79383a690179d415cdba015452b21546f0970756c4
diff --git a/dev-python/precis-i18n/metadata.xml b/dev-python/precis-i18n/metadata.xml
new file mode 100644
index 000000000000..252b16c4bd62
--- /dev/null
+++ b/dev-python/precis-i18n/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ PRECIS-i18n: Internationalized Usernames and Passwords
+
+ This module implements the PRECIS Framework as described in:
+
+ PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application Protocols (RFC 8264)
+ Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords (RFC 8265)
+ Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames (RFC 8266)
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/byllyfish/precis_i18n/issues</bugs-to>
+ <remote-id type="github">byllyfish/precis_i18n</remote-id>
+ <remote-id type="pypi">precis-i18n</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/precis-i18n/precis-i18n-1.0.0.ebuild b/dev-python/precis-i18n/precis-i18n-1.0.0.ebuild
new file mode 100644
index 000000000000..64ef7198e16e
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="https://pypi.python.org/pypi/precis-i18n"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}