summaryrefslogtreecommitdiff
path: root/dev-python/pplpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 14:43:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 14:43:50 +0100
commit7e8f2c69a019131eaeb989242d022260ea5a84ff (patch)
treece769e693cf5ee40c03b9eb7ee9ea91e24645947 /dev-python/pplpy
parent1e8bc3b2037289b8577740cea9321c37c52a49a2 (diff)
gentoo auto-resync : 26:10:2023 - 14:43:50
Diffstat (limited to 'dev-python/pplpy')
-rw-r--r--dev-python/pplpy/Manifest3
-rw-r--r--dev-python/pplpy/metadata.xml27
-rw-r--r--dev-python/pplpy/pplpy-0.8.9.ebuild49
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pplpy/Manifest b/dev-python/pplpy/Manifest
new file mode 100644
index 000000000000..19aa2df73851
--- /dev/null
+++ b/dev-python/pplpy/Manifest
@@ -0,0 +1,3 @@
+DIST pplpy-0.8.9.tar.gz 66017 BLAKE2B 90da3b4c3e992d0ca969925d8142b114fbbfd5214a768f2e56825d8689e2c4aa2e68a3fa45da9df68168a28413153eb189df277157823e88503668be5c26505c SHA512 618a0a1d603e2859313ad4f71b3cc40156a06371c6b8971fdab8275f6676fc19510e3927828c641819399b5ea6646e954738309fbf8c10fba5733c7410ed75fc
+EBUILD pplpy-0.8.9.ebuild 1178 BLAKE2B 63640d1d033c68dd82e5424c3e7a2d12666be93d9f809b6edda53a2ef0d3b49987321c5a94f09749452c28c2379ce9f1843e82932c63aea0daaa2a2ac564141a SHA512 03459c27bc6947d5d62c56a3ef1bc29866ac17de2565ca17c063409f44db3e1082d0aae94d7363597e3618c4374403195df4119e9ac006e7d1a6e424f5312c5b
+MISC metadata.xml 759 BLAKE2B 0c4fcc6e475fae1a8565c392dd82261d796b96aad68d614790e07271057b46eec4b4f89fe3be2185bc9793e828568a85df488ce568daf84555638e0516898086 SHA512 773f95dbb5635a1ffcbff57d00e6af93e173945738e67deb79bb4c628abde3793488b889bb96e9a74832d0b8c42e7274edb479c64e726ddde10ef5297be979a7
diff --git a/dev-python/pplpy/metadata.xml b/dev-python/pplpy/metadata.xml
new file mode 100644
index 000000000000..18bf8b9ca3a9
--- /dev/null
+++ b/dev-python/pplpy/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">pplpy</remote-id>
+ <remote-id type="github">sagemath/pplpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pplpy/pplpy-0.8.9.ebuild b/dev-python/pplpy/pplpy-0.8.9.ebuild
new file mode 100644
index 000000000000..91a965367055
--- /dev/null
+++ b/dev-python/pplpy/pplpy-0.8.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the Parma Polyhedra Library (PPL)"
+HOMEPAGE="https://pypi.org/project/pplpy/
+ https://github.com/sagemath/pplpy"
+
+# The file headers under ppl/ contain the "or later" bit
+LICENSE="GPL-3+"
+
+# API/ABI changes in point releases
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="dev-libs/ppl
+ dev-python/cysignals[${PYTHON_USEDEP}]
+ dev-python/gmpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile() {
+ # Parallel build breaks the test suite somehow. This should be
+ # reported upstream but first someone will need to figure out
+ # how to reproduce it outside of Gentoo.
+ distutils-r1_python_compile -j 1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all(){
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test(){
+ "${EPYTHON}" setup.py test || die
+}