summaryrefslogtreecommitdiff
path: root/dev-python/pplpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-25 07:01:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-25 07:01:01 +0000
commit50c71de793c37c19d34a68b3af53ba5e7ca51d22 (patch)
tree93bc7fabec8ef4fa120a75fa4dfefb65b839b92c /dev-python/pplpy
parent2808be9288546424bc5e88a39631a6835e6bd388 (diff)
gentoo auto-resync : 25:03:2024 - 07:01:01
Diffstat (limited to 'dev-python/pplpy')
-rw-r--r--dev-python/pplpy/Manifest2
-rw-r--r--dev-python/pplpy/pplpy-0.8.10.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pplpy/Manifest b/dev-python/pplpy/Manifest
index 574a9adfe4b4..ce67a750e9c9 100644
--- a/dev-python/pplpy/Manifest
+++ b/dev-python/pplpy/Manifest
@@ -1,3 +1,5 @@
+DIST pplpy-0.8.10.tar.gz 64203 BLAKE2B b0735722a051ef33b7415528147a84a163ac49bf5d07e2f6599a7bbf004140abf5e6a09b7f0555ac57b55614a1c059bba20cc7ac7fe47a83f429e33d7f0dd1bc SHA512 982d36291cd0108786e47cb1ff73127ba2b2a619edc697e28360a87ace743e7fc6dd04e32aab38d41724d455de4861065f9ac3d409fd2f68114b07f4d1328c23
DIST pplpy-0.8.9.tar.gz 66017 BLAKE2B 90da3b4c3e992d0ca969925d8142b114fbbfd5214a768f2e56825d8689e2c4aa2e68a3fa45da9df68168a28413153eb189df277157823e88503668be5c26505c SHA512 618a0a1d603e2859313ad4f71b3cc40156a06371c6b8971fdab8275f6676fc19510e3927828c641819399b5ea6646e954738309fbf8c10fba5733c7410ed75fc
+EBUILD pplpy-0.8.10.ebuild 1021 BLAKE2B 6c5cc32e48f303f6d740130ff423c4df53247d8b814bb57f995ec978b43b30e2f222aa4ad08403edcf2fb52b5c3aef14b9c20907bb1a82c2fed0b1c2435a9175 SHA512 52060df0f86b027412d7e9654189e71f99d737795eb5f71a65db686c4ff89f91cbe6af272352fa53e56bb9bcadc2a3d62d6fb1e4b8ea4f59f2395966d8514144
EBUILD pplpy-0.8.9.ebuild 1177 BLAKE2B 003564826013c4f1887663b6a500e8b18d33154358d4b233ae0fa4b861a15eb4372e07c66bec34e57f780c207af78c70d63a36cd879b48d21d7fcf04fccdfe5f SHA512 dbec427c8e82b69cf9939012ef5739b6b9d162ee270ecd692660815bd90e2fdd61ea652398357761a53ee1629329f8459846084fce8027ce54c8775738e86b32
MISC metadata.xml 759 BLAKE2B 0c4fcc6e475fae1a8565c392dd82261d796b96aad68d614790e07271057b46eec4b4f89fe3be2185bc9793e828568a85df488ce568daf84555638e0516898086 SHA512 773f95dbb5635a1ffcbff57d00e6af93e173945738e67deb79bb4c628abde3793488b889bb96e9a74832d0b8c42e7274edb479c64e726ddde10ef5297be979a7
diff --git a/dev-python/pplpy/pplpy-0.8.10.ebuild b/dev-python/pplpy/pplpy-0.8.10.ebuild
new file mode 100644
index 000000000000..66bea27018d0
--- /dev/null
+++ b/dev-python/pplpy/pplpy-0.8.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the Parma Polyhedra Library (PPL)"
+HOMEPAGE="
+ https://github.com/sagemath/pplpy/
+ https://pypi.org/project/pplpy/
+"
+
+# The file headers under ppl/ contain the "or later" bit
+LICENSE="GPL-3+"
+# API/ABI changes in point releases
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="
+ dev-libs/ppl
+ dev-python/cysignals[${PYTHON_USEDEP}]
+ >=dev-python/gmpy-2.1.0_beta1[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs/source
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all(){
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test(){
+ "${EPYTHON}" tests/runtests.py || die
+}