summaryrefslogtreecommitdiff
path: root/dev-python/pp/pp-1.6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pp/pp-1.6.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pp/pp-1.6.5.ebuild')
-rw-r--r--dev-python/pp/pp-1.6.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pp/pp-1.6.5.ebuild b/dev-python/pp/pp-1.6.5.ebuild
new file mode 100644
index 000000000000..4370467ae6af
--- /dev/null
+++ b/dev-python/pp/pp-1.6.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parallel and distributed programming for Python"
+HOMEPAGE="http://www.parallelpython.com/"
+SRC_URI="http://www.parallelpython.com/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+python_install_all() {
+ doman doc/ppserver.1
+ use doc && HTML_DOCS=( doc/ppdoc.html )
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}/examples"
+ fi
+ distutils-r1_python_install_all
+}