summaryrefslogtreecommitdiff
path: root/dev-python/pooch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-python/pooch
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest4
-rw-r--r--dev-python/pooch/pooch-1.2.0.ebuild25
-rw-r--r--dev-python/pooch/pooch-1.4.0.ebuild35
3 files changed, 37 insertions, 27 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index 2ae0ec4878cd..7c7ea45ea73e 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1,3 +1,3 @@
-DIST pooch-1.2.0.tar.gz 212831 BLAKE2B 73db6d6ef432960704103cee92c72d80243c9f73c3896458b20a734fc577f4982c0ecd0c72d512f8d355f28f48ca084755816196431aa7f27eab9c467e4e0654 SHA512 dfb7d890d3211f8f737dc79fa81cc895c166dc96b05d86ad2df9b33f1da950a05bce8e6a80abdb467edef2157bd13a8209771ced91a17023903c5541a1b998d3
-EBUILD pooch-1.2.0.ebuild 605 BLAKE2B 07a796f87177f96822e1596efdb351a11b31d91bccfa0607cee779c7c1296be90b3f581d6c0f7e62e4311ad536aed21c78c9ad642212c3ebe85fc8d6811692a3 SHA512 e21a097fe683c871c926a36c945df2626b8fb45f62de3d33a832fa6ef461c86b2a52ade0262795b61d5c5f5ebedd3559cfac6882f0e19d945a0548a9d28196ca
+DIST pooch-1.4.0.tar.gz 57097 BLAKE2B c891387011c99edbb78d84a8301e18fbfce36ecf6e87372ab384921d7e608abc2db2d3b3b37229ba193f3dcebb03f8df546c266075a0a35f18856ff38b3f94e2 SHA512 f883ecbb8831a179338ad497376ced25afa812ba3fdce7db4eb85aca00368aaf7c9c9f4dd58348b24f182b59e5de52bf490f03b6d4b6a807c4dcc182ac89627b
+EBUILD pooch-1.4.0.ebuild 870 BLAKE2B 0b76b07ec095ba22810c8e2ef3313413366a9a539609a309ca3c0a482cdf3382829fdb2ebb706d415a5ab53b98ca9d563ce183e186c8a66ec882eb680df9a8d2 SHA512 9d029105eed7472bec52f3c0c0de98568c6f621811dd5ca71d547f2ce5b8f28b0990828d5bd2abfe3e2027157db77a483619e2fb9f8838a5e142bdfb05d32a79
MISC metadata.xml 769 BLAKE2B 51633e3219b1a01a53469e0c395441473b8473f5fbaadbd4e5c5031de19237462d5297e12c970e018ef65ece2a56cd94ca3609a833da70ba61224c0f94607b99 SHA512 c2a24da1cf1241cd04424b37688db5a5241cbf425a9d1e29a4b7cb032847b55a5e8174bc7bff29836305e4273800693addb018e02353d081bac963f500dcccba
diff --git a/dev-python/pooch/pooch-1.2.0.ebuild b/dev-python/pooch/pooch-1.2.0.ebuild
deleted file mode 100644
index 217adcfac24a..000000000000
--- a/dev-python/pooch/pooch-1.2.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=(python3_{7..8})
-
-inherit distutils-r1
-
-DESCRIPTION="manages your Python library's sample data files"
-HOMEPAGE="https://github.com/fatiando/pooch"
-SRC_URI="https://github.com/fatiando/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}"
-
-distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
diff --git a/dev-python/pooch/pooch-1.4.0.ebuild b/dev-python/pooch/pooch-1.4.0.ebuild
new file mode 100644
index 000000000000..9108a6a076af
--- /dev/null
+++ b/dev-python/pooch/pooch-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=(python3_{7..9})
+
+inherit distutils-r1
+
+DESCRIPTION="manages your Python library's sample data files"
+HOMEPAGE="https://github.com/fatiando/pooch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+BDEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-localftpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}