summaryrefslogtreecommitdiff
path: root/dev-python/pooch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-21 05:40:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-21 05:40:28 +0000
commitb08574f4102ea8282627f075758d981eb4ba6c56 (patch)
treee9089d8d349367b6fec26823430ba5754a23e558 /dev-python/pooch
parent3fe8d2707d7ce24cce8f5d7eaa16b0b68cbaa2a4 (diff)
gentoo auto-resync : 21:02:2024 - 05:40:28
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest2
-rw-r--r--dev-python/pooch/pooch-1.8.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index 13f64d234ce7..cbb46bb6ad62 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1,3 +1,5 @@
DIST pooch-1.8.0.tar.gz 59408 BLAKE2B 07ed7c17e98ef4627f347e9b71355e147f56970fe5f0d709269602796a5ba2d8ffd5ad0ad47a17114d32841b9a7fc3eeab978f8ca9f64d35c89ff35b0aa62279 SHA512 d97e3e1098d1eeee30108affc64ed5a12f679e9122d35494598a03f3a548bb83b57dc54ac5a2c85bc42e664cb90f713bdb55b47b430ff000a722ffad58010497
+DIST pooch-1.8.1.tar.gz 59614 BLAKE2B ff30e6f1a1cc71091d5e822eb0eeda59fb1ff8f53d2dd6dc67dccc955d28f3fa485d03615d544096fdae7786c181a3395b62e3c59212f80b977755e3df0addf0 SHA512 9e78da7839deb443340c925622d5e9b1d7a3f14fdac3eae2528fb91ebf86f88715e8737e869057fe7c703e8423303e15379c07e5d11a7bebd3da63b1ac06ae3f
EBUILD pooch-1.8.0.ebuild 1777 BLAKE2B e9bb96b23480b4db627a516d1a10269510b49de48afeead135b13c13b667c9c4f85c660bf3de22f7dff762cc18e958f3f1f7912b2812a77c60d9db841f6e319b SHA512 70810a56585e2a4a7b3f46202cf46059f6be589a41b99b9d1194b9b6fe215af62f29a85befbf2cf727cdea86f5f3f2ccfcff947c7c17872ba4a70b18c8d40f4c
+EBUILD pooch-1.8.1.ebuild 1783 BLAKE2B b8e14847f6a518db2ee58d48420b293d55630d58df9e7c2f3277100cad07fee4aaad774703c2bc61b4c0221823f9a2120a837c0a82f0b829ef535a17db534317 SHA512 c18d5cc6e064cd330b1bb66db634b1541296154b10e06f2792003c965f31f81df33ced0296835570d15999d255da0d19ca4b51152da2a628fd5d86f3eaa212bc
MISC metadata.xml 684 BLAKE2B b6cd1db5a31f316800c9c5e15e11c858bebc81b7c38ced227e7f54a5a0386462fa9a92bb8f177d9df0d3fea00775dced1e2eebbb1622fededdac87ce40db21e7 SHA512 a96adfa4b8996e2685f7d5ea8ab6936fcc795a3f517da8ec14e885c08b2ae1f6d950ea9314e8aa6a4b2a4b436a23d1e98a6d56b5ae0c633bffc4fbeaca4058a4
diff --git a/dev-python/pooch/pooch-1.8.1.ebuild b/dev-python/pooch/pooch-1.8.1.ebuild
new file mode 100644
index 000000000000..c6e63ad9b1a0
--- /dev/null
+++ b/dev-python/pooch/pooch-1.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage your Python library's sample data files"
+HOMEPAGE="
+ https://github.com/fatiando/pooch/
+ https://pypi.org/project/pooch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Needs network
+ pooch/tests/test_core.py::test_check_availability_invalid_downloader
+ pooch/tests/test_core.py::test_load_registry_from_doi
+ pooch/tests/test_core.py::test_load_registry_from_doi_zenodo_with_slash
+ # dev-python/pytest-localftpserver -> dev-python/pyftpdlib has py3.12 issues
+ # https://github.com/giampaolo/pyftpdlib/issues/560#issuecomment-971377238
+ pooch/tests/test_core.py::test_check_availability_on_ftp
+ pooch/tests/test_downloaders.py::test_invalid_doi_repository
+ pooch/tests/test_downloaders.py::test_doi_url_not_found
+ pooch/tests/test_downloaders.py::test_figshare_url_file_not_found
+ pooch/tests/test_downloaders.py::test_doi_downloader
+)
+
+### docs no included in pypi tarball
+# distutils_enable_sphinx doc \
+# dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver -k "not network"
+}