summaryrefslogtreecommitdiff
path: root/dev-python/pooch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
commit2de9aaae9b6018544ada7f67e2229605e1ec4d04 (patch)
tree231bad5690196ca522285d446614a065879cc7d0 /dev-python/pooch
parent4274bed0c1f1fd06a654f5816e30d82059f4cc39 (diff)
gentoo auto-resync : 05:04:2023 - 23:26:20
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest2
-rw-r--r--dev-python/pooch/pooch-1.6.0.ebuild52
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index e03f40113a77..c14ba415a1aa 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1,5 +1,3 @@
-DIST pooch-1.6.0.tar.gz 52318 BLAKE2B c5cdf04a27a5754accee5a4522d5e6a51c4e71b7034cd570c6a2f30bc580ba9c15e0717be792e7cdd020ca745e6813a63681ce966ad61c0ed4aaa8b84829b920 SHA512 e1b6253b8879ef172bd6370139a7807355c7e1c03a1626ac46cb083b1f7d8beb5a8adb08c0828eb34e96a7164211d2dc7da214fd0176eb0606fe4ff47911257c
DIST pooch-1.7.0.tar.gz 57457 BLAKE2B d85fc3cc707bfa639f46bf75b89dd31714f7a4f64a90ff7a6c92b792a8209e66a5fffb62912a336cd481330c37c0037df116d27ea06808bf02f1039e2aac930b SHA512 60126b893a9a1422aad12349143fbe72e485004f79b06da752f51ae374f375efae693304210c8d62b211433d7ce75fab53a50a6f267b1952df83fdccc2de13a7
-EBUILD pooch-1.6.0.ebuild 1494 BLAKE2B 860b2350a1b6bc39f7f309df68ac345e2379f75108a9ce403bbe20cff2f9d8a1d078892255a9a2d72bfbab3175d01a3d0423d9621624d7b40d8b23d1c4620950 SHA512 8340aa94d27763d42a4eb75fb1b312b3b2c373013df547e627bb38594ed6d3f7525916ceadd9d6cf84f739f17806073f4a89f8769d60fd163d714313c8320306
EBUILD pooch-1.7.0.ebuild 1461 BLAKE2B ac0d688807b246f5331ab726c6fdae23ccdce659afc4cb42af7ef9bbd1d170a6320c805c328ee4782cc613b305aedcc96f8cb75d610e8ac2737d927c62c95166 SHA512 1a332337162aebd5358ebeeb85933893534b2913c43036f6797536bf2d43c78b4813cf6962f2e506245a0564bb00ef0ed282959c11dfac7066c14e9886ad42f4
MISC metadata.xml 684 BLAKE2B b6cd1db5a31f316800c9c5e15e11c858bebc81b7c38ced227e7f54a5a0386462fa9a92bb8f177d9df0d3fea00775dced1e2eebbb1622fededdac87ce40db21e7 SHA512 a96adfa4b8996e2685f7d5ea8ab6936fcc795a3f517da8ec14e885c08b2ae1f6d950ea9314e8aa6a4b2a4b436a23d1e98a6d56b5ae0c633bffc4fbeaca4058a4
diff --git a/dev-python/pooch/pooch-1.6.0.ebuild b/dev-python/pooch/pooch-1.6.0.ebuild
deleted file mode 100644
index 4cedb5112453..000000000000
--- a/dev-python/pooch/pooch-1.6.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Manage your Python library's sample data files"
-HOMEPAGE="https://github.com/fatiando/pooch"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/pytest-localftpserver[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_DESELECT=(
- # Needs network
- "pooch/tests/test_core.py::test_check_availability_on_ftp"
- "pooch/tests/test_downloaders.py::test_invalid_doi_repository"
- "pooch/tests/test_downloaders.py::test_doi_url_not_found"
- "pooch/tests/test_downloaders.py::test_figshare_url_file_not_found[figshare]"
- "pooch/tests/test_downloaders.py::test_figshare_url_file_not_found[zenodo]"
- "pooch/tests/test_downloaders.py::test_doi_downloader[figshare]"
- "pooch/tests/test_downloaders.py::test_doi_downloader[zenodo]"
-)
-
-### docs no included in pypi tarball
-# distutils_enable_sphinx doc \
-# dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- epytest -k "not network"
-}