summaryrefslogtreecommitdiff
path: root/dev-python/pooch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 10:03:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 10:03:38 +0000
commit24a48769f03b243065aec42c384c39a2d2306964 (patch)
tree6ee4e01247ea4cbdae0b2c9e6b88d86658fae0d3 /dev-python/pooch
parent87f37a073fb5c2e1f6ebc780e60cdbdd2c583860 (diff)
gentoo auto-resync : 28:02:2023 - 10:03:37
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest2
-rw-r--r--dev-python/pooch/pooch-1.7.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index 0d14503d2e93..1c20e9e8d0cd 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1,3 +1,5 @@
DIST pooch-1.6.0.tar.gz 52318 BLAKE2B c5cdf04a27a5754accee5a4522d5e6a51c4e71b7034cd570c6a2f30bc580ba9c15e0717be792e7cdd020ca745e6813a63681ce966ad61c0ed4aaa8b84829b920 SHA512 e1b6253b8879ef172bd6370139a7807355c7e1c03a1626ac46cb083b1f7d8beb5a8adb08c0828eb34e96a7164211d2dc7da214fd0176eb0606fe4ff47911257c
+DIST pooch-1.7.0.tar.gz 57457 BLAKE2B d85fc3cc707bfa639f46bf75b89dd31714f7a4f64a90ff7a6c92b792a8209e66a5fffb62912a336cd481330c37c0037df116d27ea06808bf02f1039e2aac930b SHA512 60126b893a9a1422aad12349143fbe72e485004f79b06da752f51ae374f375efae693304210c8d62b211433d7ce75fab53a50a6f267b1952df83fdccc2de13a7
EBUILD pooch-1.6.0.ebuild 1495 BLAKE2B af4f5a368444f056aba1d64ecd4dc979e646eafc64c4fb29006c0d6d4ed11fc58f613c0465ecfb22109c8065b1b762c9b3c4ad00ce19f165ae1eff1c21cc7bdb SHA512 5feca74ce5b8f805786403caaf0c745a634d81840ee0f158c23945139bd28012a8803eb88f1df5a79197d7000e9689d29a143ca55be030fc63d536aaec836a71
+EBUILD pooch-1.7.0.ebuild 1467 BLAKE2B 34e7664ba0629935ba6e378b0cbd5b123827ab4423bf1575b82cca49137439c392a4de29c8c6465f3369268bdc382886f496951b693abda69d4804193c68d92c SHA512 0e1037a476f98ec2419ccae92f13a52ba04060f7719aac8456e50eaccfb3729a9515053b85c4858366d420d4a940960e07785969c1fa0548d240796096027184
MISC metadata.xml 684 BLAKE2B b6cd1db5a31f316800c9c5e15e11c858bebc81b7c38ced227e7f54a5a0386462fa9a92bb8f177d9df0d3fea00775dced1e2eebbb1622fededdac87ce40db21e7 SHA512 a96adfa4b8996e2685f7d5ea8ab6936fcc795a3f517da8ec14e885c08b2ae1f6d950ea9314e8aa6a4b2a4b436a23d1e98a6d56b5ae0c633bffc4fbeaca4058a4
diff --git a/dev-python/pooch/pooch-1.7.0.ebuild b/dev-python/pooch/pooch-1.7.0.ebuild
new file mode 100644
index 000000000000..2cc8a7f0a32f
--- /dev/null
+++ b/dev-python/pooch/pooch-1.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage your Python library's sample data files"
+HOMEPAGE="
+ https://github.com/fatiando/pooch/
+ https://pypi.org/project/pooch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-localftpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Needs network
+ pooch/tests/test_core.py::test_check_availability_invalid_downloader
+ pooch/tests/test_core.py::test_load_registry_from_doi
+ pooch/tests/test_core.py::test_load_registry_from_doi_zenodo_with_slash
+ pooch/tests/test_downloaders.py::test_invalid_doi_repository
+ pooch/tests/test_downloaders.py::test_doi_url_not_found
+ pooch/tests/test_downloaders.py::test_figshare_url_file_not_found
+ pooch/tests/test_downloaders.py::test_doi_downloader
+)
+
+### docs no included in pypi tarball
+# distutils_enable_sphinx doc \
+# dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -k "not network"
+}