summaryrefslogtreecommitdiff
path: root/dev-python/pooch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 14:40:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 14:40:37 +0100
commit2000f81da4dc9971f6e1e5d00b315816d4188f4c (patch)
tree479704e6bf1eeba3c58172680d8bc26b87c71e68 /dev-python/pooch
parent6d57946e8f20a2294b96eca2e379d3e8e1c93384 (diff)
gentoo auto-resync : 25:10:2023 - 14:40:37
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest2
-rw-r--r--dev-python/pooch/pooch-1.8.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index 3bb97d9b47b6..d58777040a5c 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1,3 +1,5 @@
DIST pooch-1.7.0.tar.gz 57457 BLAKE2B d85fc3cc707bfa639f46bf75b89dd31714f7a4f64a90ff7a6c92b792a8209e66a5fffb62912a336cd481330c37c0037df116d27ea06808bf02f1039e2aac930b SHA512 60126b893a9a1422aad12349143fbe72e485004f79b06da752f51ae374f375efae693304210c8d62b211433d7ce75fab53a50a6f267b1952df83fdccc2de13a7
+DIST pooch-1.8.0.tar.gz 59408 BLAKE2B 07ed7c17e98ef4627f347e9b71355e147f56970fe5f0d709269602796a5ba2d8ffd5ad0ad47a17114d32841b9a7fc3eeab978f8ca9f64d35c89ff35b0aa62279 SHA512 d97e3e1098d1eeee30108affc64ed5a12f679e9122d35494598a03f3a548bb83b57dc54ac5a2c85bc42e664cb90f713bdb55b47b430ff000a722ffad58010497
EBUILD pooch-1.7.0.ebuild 1658 BLAKE2B 1aa7c9b1cfcf8e8a7ef917746dc0c3f447349ae76c8aaa977631bd84204c9105237c35f890fff7df5c71bdbf5cf5a53ef43a272657806406f0849de6f5e92869 SHA512 10cee7c729e7894777d979ddb05deefd5c8a427182b08ac40edc886943ba33bb147e3e7839f252fdadddbe5b44dfd43b8eecd8e63d9692ac6435afa39c20ba44
+EBUILD pooch-1.8.0.ebuild 1777 BLAKE2B 97cd29a6de408f5966371018e545d10d875a9c7d13cdf778ae37b748b979ac1f77e3784297b8149300cc5165ef0f4be93b217fdd10f02ee8205141c7baf6464b SHA512 2f7385bb0e24b2604ad061b915fd88f07fffd7442f4029aa1e110ca880ef143928f31785296f71e31050dbef8c481ffb682c594c88023cbd3254e13ce61f888b
MISC metadata.xml 684 BLAKE2B b6cd1db5a31f316800c9c5e15e11c858bebc81b7c38ced227e7f54a5a0386462fa9a92bb8f177d9df0d3fea00775dced1e2eebbb1622fededdac87ce40db21e7 SHA512 a96adfa4b8996e2685f7d5ea8ab6936fcc795a3f517da8ec14e885c08b2ae1f6d950ea9314e8aa6a4b2a4b436a23d1e98a6d56b5ae0c633bffc4fbeaca4058a4
diff --git a/dev-python/pooch/pooch-1.8.0.ebuild b/dev-python/pooch/pooch-1.8.0.ebuild
new file mode 100644
index 000000000000..48526d352cdf
--- /dev/null
+++ b/dev-python/pooch/pooch-1.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage your Python library's sample data files"
+HOMEPAGE="
+ https://github.com/fatiando/pooch/
+ https://pypi.org/project/pooch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Needs network
+ pooch/tests/test_core.py::test_check_availability_invalid_downloader
+ pooch/tests/test_core.py::test_load_registry_from_doi
+ pooch/tests/test_core.py::test_load_registry_from_doi_zenodo_with_slash
+ # dev-python/pytest-localftpserver -> dev-python/pyftpdlib has py3.12 issues
+ # https://github.com/giampaolo/pyftpdlib/issues/560#issuecomment-971377238
+ pooch/tests/test_core.py::test_check_availability_on_ftp
+ pooch/tests/test_downloaders.py::test_invalid_doi_repository
+ pooch/tests/test_downloaders.py::test_doi_url_not_found
+ pooch/tests/test_downloaders.py::test_figshare_url_file_not_found
+ pooch/tests/test_downloaders.py::test_doi_downloader
+)
+
+### docs no included in pypi tarball
+# distutils_enable_sphinx doc \
+# dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver -k "not network"
+}