summaryrefslogtreecommitdiff
path: root/dev-python/pony
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pony
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pony')
-rw-r--r--dev-python/pony/Manifest4
-rw-r--r--dev-python/pony/pony-0.7.15.ebuild25
-rw-r--r--dev-python/pony/pony-0.7.16.ebuild25
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pony/Manifest b/dev-python/pony/Manifest
index 499b084c29bb..1c057715e75d 100644
--- a/dev-python/pony/Manifest
+++ b/dev-python/pony/Manifest
@@ -1,3 +1,7 @@
DIST pony-0.7.14.gh.tar.gz 305795 BLAKE2B a0e056d722a205a00567a230628be6ef8a7fe86f594f91ec0e8bbfc6d6eec17ec1d4cf3f57ad10984b8beb0a90da3010d9a32f2f08dca434af39e20fc6e9126c SHA512 ed27fd697dd14948c282dab6b75e41c9309d0ef4c4cccb0f91e4214e81de52a2de3910e413dfc5495ffcea190a5b50255c45b2beecead84eecb601ba2463d998
+DIST pony-0.7.15.gh.tar.gz 268638 BLAKE2B d93dcc21a13834a23c0fcbeec7f6ea98ff6750d1650b00e738d65c7b7985ba7880ddfc8238e4b4f3ee4a302a31b69a4767ea52728e66b5cfe62e0190769e6b8c SHA512 ca81441fe1a714bc863bde33739ae2e65f42d8e763a5c6734517987a4c03faffb08a134517bcc61f5b7941f207e32e4ca02fe12fccca871d481f44a81da12536
+DIST pony-0.7.16.gh.tar.gz 268683 BLAKE2B bee6447116f215cd586e69f29fea37ba3f9953d0a72b28acf612da2d6e1be07e424b704593e42ae1755e898580aaf4f2e61923ff81e6e58fe0cc8ec04a3b8399 SHA512 db9bb06f0e718866eb6f137d5650a2b484119c42f1ade83a7bc1c9e3c27a852ed25e451a226a80bebd050ca3217c0993e59f3b66719a3fe41a98e45349172495
EBUILD pony-0.7.14.ebuild 595 BLAKE2B aae16f52a5f10a0a6d586b449269fa90308da6f02f548e4b245a2ccd73aadd515d7516196047c219597ed0634a11a7dfcc63fd8026db33e7da219ca620d32fcc SHA512 fa2d13306be095b06a62aed03767ee4286b3c3aa1fe2f53a67fd78bb95ba31b3080742b39791a054caae2740be908eda800a705035a2df4fbcf81b6785c8e20e
+EBUILD pony-0.7.15.ebuild 591 BLAKE2B b7b3ca9dad7c1a4035896a2f5035eca9d8f61ed7b0e0aec59321e5f7c1dfe5843b81f7fa4d5c3e2b062ec79e901a9e357ed49704ac4740a04b8f83a099717aec SHA512 44f333aac73be9d1a8724b76031e26cad1dd2dce05e5a0ae626f01a99c43cfc673da2621c222bc187f4666050cc1cf2bff34adfa0fa9c11393624220f00d3a14
+EBUILD pony-0.7.16.ebuild 591 BLAKE2B b7b3ca9dad7c1a4035896a2f5035eca9d8f61ed7b0e0aec59321e5f7c1dfe5843b81f7fa4d5c3e2b062ec79e901a9e357ed49704ac4740a04b8f83a099717aec SHA512 44f333aac73be9d1a8724b76031e26cad1dd2dce05e5a0ae626f01a99c43cfc673da2621c222bc187f4666050cc1cf2bff34adfa0fa9c11393624220f00d3a14
MISC metadata.xml 310 BLAKE2B ed4d2ed3e7c512043c05677c507475616cd70192c0f9360f57e7c3bf35ebfe739a8fe51d6027abf10b1027891c9f13aabcc85a2e7808a6f065b79a72c17541ea SHA512 8379f9a411ed18e95da3caf48ba6e5e4d6f86003e5b633f3393e2fe82d4b8c0afa1a77202f637f1144ff0eb07fea115542f346f360bf853697f3559fd26b4333
diff --git a/dev-python/pony/pony-0.7.15.ebuild b/dev-python/pony/pony-0.7.15.ebuild
new file mode 100644
index 000000000000..2260573d4ebf
--- /dev/null
+++ b/dev-python/pony/pony-0.7.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python ORM with beautiful query syntax"
+HOMEPAGE="
+ https://ponyorm.org/
+ https://github.com/ponyorm/pony/"
+SRC_URI="
+ https://github.com/ponyorm/pony/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+BDEPEND="test? ( $(python_gen_impl_dep sqlite) )"
+
+distutils_enable_tests unittest
diff --git a/dev-python/pony/pony-0.7.16.ebuild b/dev-python/pony/pony-0.7.16.ebuild
new file mode 100644
index 000000000000..2260573d4ebf
--- /dev/null
+++ b/dev-python/pony/pony-0.7.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python ORM with beautiful query syntax"
+HOMEPAGE="
+ https://ponyorm.org/
+ https://github.com/ponyorm/pony/"
+SRC_URI="
+ https://github.com/ponyorm/pony/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+BDEPEND="test? ( $(python_gen_impl_dep sqlite) )"
+
+distutils_enable_tests unittest