summaryrefslogtreecommitdiff
path: root/dev-python/polygon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-python/polygon
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-python/polygon')
-rw-r--r--dev-python/polygon/Manifest2
-rw-r--r--dev-python/polygon/polygon-3.0.7.ebuild13
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/polygon/Manifest b/dev-python/polygon/Manifest
index 587e67926115..496e239f01ca 100644
--- a/dev-python/polygon/Manifest
+++ b/dev-python/polygon/Manifest
@@ -1,3 +1,3 @@
DIST Polygon3-3.0.7.zip 76193 BLAKE2B 57ef62b6652400be057e8596f705e2112caef09208aafa7e46686f86367181dc078cbfc6ade99af22cce7fc0a76ec1de2995885ba4c11263444ca315029c38d7 SHA512 e30cd8e51ad69a2d76b61a7d92ead4ac352e729093546b965f649866fd9c6a860e3cdcd9fcd7f8cc9f8d7735ccd1128fb5af00b3de89e4efd7128e446a70b33b
-EBUILD polygon-3.0.7.ebuild 960 BLAKE2B 20dfbd2898c605e5f3da14eca64d38a3d803d6661547937bda1d417fec312680c96be1e72719c2260002d06dc4467f376bea03175cedffdbaa1f45fca72e3d2f SHA512 3295f0d55ab38f790a1f2088eab9002a3d5694002598c5ea200f88bf2d709657f7f15c9fba958e621a532eb4abd7623b313ec951c5f4a9f2ce8a61eff15d8aea
+EBUILD polygon-3.0.7.ebuild 963 BLAKE2B 859e85a0966c94b227260cc4b805e904196a664d20ba2605db959dec7d6b38e34dbf3c83a24a488524b93a1f05efc2300dc80f9f19b1b4454dce72ecbe146cea SHA512 314d2e08c05d162a9ddfcd525e2fb7d1c6c755698e43a5dce14f2ca49b9e7398ce6a6b64bc720a5ba6da6824f8aa74abe357c9fc738c3a993b9f59ff2a48ccf8
MISC metadata.xml 568 BLAKE2B e3bdc0a656df511c6ce8de4c7bde5c5acbde8dd6f1b453dc517ffd89a2116c437a9533e1cbe6ece06be7f517b729ea27930584265a130f108c9d16db3bd397e4 SHA512 5724f779e98b0e0d0dd12bc68d697f003f281e4fb2af68c9e7ef4182cd4654a7e2a00435ab5246d2f696dbb6ec673ed5dcdc9bd771d3bde5aa7f63ecd5c1172e
diff --git a/dev-python/polygon/polygon-3.0.7.ebuild b/dev-python/polygon/polygon-3.0.7.ebuild
index e9821f63b466..7e55b589af0f 100644
--- a/dev-python/polygon/polygon-3.0.7.ebuild
+++ b/dev-python/polygon/polygon-3.0.7.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -14,12 +14,12 @@ SRC_URI="https://www.bitbucket.org/jraedler/${PN}3/downloads/Polygon3-${PV}.zip"
LICENSE="LGPL-2"
SLOT="3"
-IUSE="examples"
KEYWORDS="amd64 ppc x86"
+IUSE="examples"
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
-S=${WORKDIR}/Polygon3-${PV}
+S="${WORKDIR}/Polygon3-${PV}"
DOCS=( doc/{Polygon.txt,Polygon.pdf} )
@@ -28,6 +28,7 @@ python_prepare_all() {
mkdir examples || die
mv doc/{Examples.py,testpoly.gpf} examples || die
fi
+
distutils-r1_python_prepare_all
}