summaryrefslogtreecommitdiff
path: root/dev-python/polygon/polygon-3.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/polygon/polygon-3.0.7.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/polygon/polygon-3.0.7.ebuild')
-rw-r--r--dev-python/polygon/polygon-3.0.7.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/polygon/polygon-3.0.7.ebuild b/dev-python/polygon/polygon-3.0.7.ebuild
deleted file mode 100644
index 4932e85b87cc..000000000000
--- a/dev-python/polygon/polygon-3.0.7.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python package to handle polygonal shapes in 2D"
-HOMEPAGE="https://www.j-raedler.de/projects/polygon/"
-SRC_URI="https://www.bitbucket.org/jraedler/${PN}3/downloads/Polygon3-${PV}.zip"
-
-LICENSE="LGPL-2"
-SLOT="3"
-IUSE="examples"
-KEYWORDS="amd64 ppc x86"
-
-DEPEND="app-arch/unzip"
-
-S=${WORKDIR}/Polygon3-${PV}
-
-DOCS=( doc/{Polygon.txt,Polygon.pdf} )
-
-python_prepare_all() {
- if use examples; then
- mkdir examples || die
- mv doc/{Examples.py,testpoly.gpf} examples || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ${PYTHON} test/Test.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}