summaryrefslogtreecommitdiff
path: root/dev-python/poetry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-14 10:46:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-14 10:46:43 +0100
commitd938920a33f03124f4e211a67d9291283442caa1 (patch)
tree8df88b987b9cf96366e7bdab6bec0f5606c6153d /dev-python/poetry
parent8d3092381b8c63ad0261911737e91cc4fda109c9 (diff)
gentoo auto-resync : 14:09:2023 - 10:46:43
Diffstat (limited to 'dev-python/poetry')
-rw-r--r--dev-python/poetry/Manifest1
-rw-r--r--dev-python/poetry/poetry-1.6.1-r1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
index 8a088421d1ab..9976cea30fdb 100644
--- a/dev-python/poetry/Manifest
+++ b/dev-python/poetry/Manifest
@@ -3,5 +3,6 @@ DIST poetry-1.6.0.tar.gz 1475454 BLAKE2B 11bdfb5cacee0563d134919619bffeb007c13c6
DIST poetry-1.6.1.tar.gz 1475487 BLAKE2B 0e49da3473203fcd24aacdf34e886bb4a6e723bc1e03ccc285c94a25f214b31c768462fef0cc24f659132dd5ce33eac71a2329fef4df7dba1c76303fd1987a77 SHA512 3d5aac641c0fa4dd16f8f7b2a55fa1795ced1803886a048167a0a2a2ac419ff1c16734458316100f54ca4e8bcf88b5aa176b0ba2bde74bee6bdd41305b078f3b
EBUILD poetry-1.5.1-r2.ebuild 4205 BLAKE2B c47e2786a7f7ef77a59bf2584278febabe8fdf3952a56023d716c3f8c1724055feb78f800ef0862b353ddf2db54460daf1897e6ec60a1d82209704a5858969b1 SHA512 c0f928e7e073eabd13a8abffb0713c47b517eff8987654a0770d9a6f5aed96009f4e1aea668a355f2f00d7520c9d2196724a3d550001651eb57420facb7517cc
EBUILD poetry-1.6.0.ebuild 3086 BLAKE2B 8880c9480fedda0a7b79bbe86da129ef655d2292ee74ea37fbf0942cb4cb653873e3e51a37435dc5e61e97c98f697b0552c61e49d9fee2e91f715d9e370428ae SHA512 6edc0b8ed14dd3b6534b15befbec75348bda618349078a4cba63886c8d9cbb00b4a749391b1f499ef373ef96038107bf947e2378573755da42ab4490f3ff303c
+EBUILD poetry-1.6.1-r1.ebuild 3193 BLAKE2B 79ebdaf68abda70dac08c81412e129ad55745b7ae46bf1a8c2b59dfe2068a529afdfc360c5ad4b9cd1e460552a553a04076e43ecb4dd76e94a114c453c43c6a5 SHA512 f6c3a2347607b707d86c766a1d1604a6ae1d2265621579a2deee513cc40efabaf3aa93d66c47c4e64fdb1ad80b66c41743abe2d1bdd441a95348fae055486838
EBUILD poetry-1.6.1.ebuild 3087 BLAKE2B 821bc5a170adb4d5271836d52d5a3988ac37bd6ef0eae18399fbb2ffd1299252df09f67ea34aa63b7746926b58ca35d0dcdd4d090a3f1b8e96e285fa42d65dd7 SHA512 587c808f8b8f609777046699fb4e5f9028114db30a5414c1d3585dfaf405de6401e0591340a8ca5ee2860e2b16de5d7b1ce8d0ebb881d4c329a8eb91f9a1cffb
MISC metadata.xml 486 BLAKE2B 7757afe2f964f49a04a600ec80af8511387c3a80105c9050755e1815cac148734f540e4da8c1da401c15a63bf5d0a8200ed6a5e1c09e5dacc7d39f5f59dd343f SHA512 541063e55b4dc5b927ef4ff6b385663bbf978d13ac6644c2537483ec42f211780cab4d881b159894dfe86519b4655c80bcfe17cdb90a2e033077b390a3842f46
diff --git a/dev-python/poetry/poetry-1.6.1-r1.ebuild b/dev-python/poetry/poetry-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..b05b1bb96d19
--- /dev/null
+++ b/dev-python/poetry/poetry-1.6.1-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A frontend for poetry - a python dependency management and packaging tool"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry
+ https://pypi.org/project/poetry/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# dev-python/build: 1.0 breaks backward compatibility
+# https://github.com/python-poetry/poetry/issues/8434
+RDEPEND="
+ >=dev-python/poetry-core-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/poetry-plugin-export-1.5.0[${PYTHON_USEDEP}]
+ <dev-python/build-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cachecontrol-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/cleo-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/crashtest-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.21.2[${PYTHON_USEDEP}]
+ >=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.10.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-24.0.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+ >=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.22.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # unpin
+ sed -e 's:\^:>=:' \
+ -e '/poetry-core/s:":">=:' \
+ -e 's:,<[0-9.]*::' \
+ -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Tests require network (they run `pip install ...`)
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_directories
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git_with_subdirectories
+ tests/installation/test_pip_installer.py::test_uninstall_git_package_nspkg_pth_cleanup
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_non_wheel_files
+ tests/installation/test_installer.py::test_installer_with_pypi_repository
+ tests/masonry/builders/test_editable_builder.py::test_builder_setup_generation_runs_with_pip_editable
+
+ # Works with network, but otherwise: Backend 'poetry.core.masonry.api' is not available.
+ tests/installation/test_chef.py::test_prepare_sdist
+ tests/installation/test_chef.py::test_prepare_directory
+ tests/installation/test_chef.py::test_prepare_directory_with_extensions
+ tests/installation/test_chef.py::test_prepare_directory_editable
+)
+
+distutils_enable_tests pytest