summaryrefslogtreecommitdiff
path: root/dev-python/poetry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 09:43:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 09:43:30 +0100
commit28e28adc401b344fa5c230e2609c542873c372f8 (patch)
treece600e2ae889fb50ee1d80dd98a1f30886081bcd /dev-python/poetry
parent855f2ab2714a36dd2d3b757890b2449d3e9155f2 (diff)
gentoo auto-resync : 21:08:2023 - 09:43:30
Diffstat (limited to 'dev-python/poetry')
-rw-r--r--dev-python/poetry/Manifest2
-rw-r--r--dev-python/poetry/poetry-1.6.0.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
index 0ca432089ce7..5fd691bd9fd4 100644
--- a/dev-python/poetry/Manifest
+++ b/dev-python/poetry/Manifest
@@ -1,3 +1,5 @@
DIST poetry-1.5.1.tar.gz 1469755 BLAKE2B ac60d6aabe69b1e46a6fbc188579034e716a470384571a611952489d175485cf997636c9206a53e29be073582e672f8010ab5f8f13b58a12dc644279753f903e SHA512 863bc4ea43b6fc5b340f50f007c76d2c253223d6bd55ea5c1ead4bc353c3d4cd85d51372a774276e14d9fca733fac9c2f582892fec950b74f25dc188dafa7a96
+DIST poetry-1.6.0.tar.gz 1475454 BLAKE2B 11bdfb5cacee0563d134919619bffeb007c13c632d8ab017521ce191a5ccaace52405ef9afa81ece1042c075b4601069deab99028a187bea73d4d6e4b505b55f SHA512 eef9a4c4d0526d3c71380c00b654852b22b7c5e86f187463977b1f798b5cb377c41983a6c21350c19f13fb1804a8190f5bd158dc5f0a298d0732812e44524063
EBUILD poetry-1.5.1-r2.ebuild 4205 BLAKE2B c47e2786a7f7ef77a59bf2584278febabe8fdf3952a56023d716c3f8c1724055feb78f800ef0862b353ddf2db54460daf1897e6ec60a1d82209704a5858969b1 SHA512 c0f928e7e073eabd13a8abffb0713c47b517eff8987654a0770d9a6f5aed96009f4e1aea668a355f2f00d7520c9d2196724a3d550001651eb57420facb7517cc
+EBUILD poetry-1.6.0.ebuild 3086 BLAKE2B 8880c9480fedda0a7b79bbe86da129ef655d2292ee74ea37fbf0942cb4cb653873e3e51a37435dc5e61e97c98f697b0552c61e49d9fee2e91f715d9e370428ae SHA512 6edc0b8ed14dd3b6534b15befbec75348bda618349078a4cba63886c8d9cbb00b4a749391b1f499ef373ef96038107bf947e2378573755da42ab4490f3ff303c
MISC metadata.xml 486 BLAKE2B 7757afe2f964f49a04a600ec80af8511387c3a80105c9050755e1815cac148734f540e4da8c1da401c15a63bf5d0a8200ed6a5e1c09e5dacc7d39f5f59dd343f SHA512 541063e55b4dc5b927ef4ff6b385663bbf978d13ac6644c2537483ec42f211780cab4d881b159894dfe86519b4655c80bcfe17cdb90a2e033077b390a3842f46
diff --git a/dev-python/poetry/poetry-1.6.0.ebuild b/dev-python/poetry/poetry-1.6.0.ebuild
new file mode 100644
index 000000000000..cf1401fefdd6
--- /dev/null
+++ b/dev-python/poetry/poetry-1.6.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A frontend for poetry - a python dependency management and packaging tool"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry
+ https://pypi.org/project/poetry/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/poetry-plugin-export-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/build-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/cachecontrol-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/cleo-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/crashtest-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.21.2[${PYTHON_USEDEP}]
+ >=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.10.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-24.0.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+ >=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.22.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # unpin
+ sed -e 's:\^:>=:' \
+ -e '/poetry-core/s:":">=:' \
+ -e 's:,<[0-9.]*::' \
+ -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Tests require network (they run `pip install ...`)
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_directories
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git_with_subdirectories
+ tests/installation/test_pip_installer.py::test_uninstall_git_package_nspkg_pth_cleanup
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_non_wheel_files
+ tests/installation/test_installer.py::test_installer_with_pypi_repository
+ tests/masonry/builders/test_editable_builder.py::test_builder_setup_generation_runs_with_pip_editable
+
+ # Works with network, but otherwise: Backend 'poetry.core.masonry.api' is not available.
+ tests/installation/test_chef.py::test_prepare_sdist
+ tests/installation/test_chef.py::test_prepare_directory
+ tests/installation/test_chef.py::test_prepare_directory_with_extensions
+ tests/installation/test_chef.py::test_prepare_directory_editable
+)
+
+distutils_enable_tests pytest