summaryrefslogtreecommitdiff
path: root/dev-python/poetry-plugin-export
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-16 12:48:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-16 12:48:38 +0000
commitd08ea43e9ada434f42f4be8e115b67ab22ce38af (patch)
treebdc9f44b886b8b704d67c2417df0b7b2055a2976 /dev-python/poetry-plugin-export
parent80ea6e6ea87f4685ceff45cd13dd00d644688cac (diff)
gentoo auto-resync : 16:03:2024 - 12:48:37
Diffstat (limited to 'dev-python/poetry-plugin-export')
-rw-r--r--dev-python/poetry-plugin-export/Manifest2
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.7.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/Manifest b/dev-python/poetry-plugin-export/Manifest
index ac620169d10a..09e1ee7be5de 100644
--- a/dev-python/poetry-plugin-export/Manifest
+++ b/dev-python/poetry-plugin-export/Manifest
@@ -1,3 +1,5 @@
DIST poetry_plugin_export-1.6.0.tar.gz 29265 BLAKE2B 90690afe197fd109d5fc5ae4566675a6a1e5e4df50cd814370146501389ba3bb0e78c2be2878cac322548ea5be065ef68f5b28a6d79a003d0f7b31c149ad0214 SHA512 d071f69ace98dbc23a3b129ba7fb30c4e6eac07138f4ee5156c266150f8f025f8b69c61dfadd90d29e1895c70d448fc44a9b5cc502024f00e1657247ed3310bd
+DIST poetry_plugin_export-1.7.0.tar.gz 29196 BLAKE2B dc3db16ceee5cc727c865e141527ce4c854b2b68050ab8e4c7d03a2912f8fc7c3310653c098510198aea6254b35c875d9e837e129d327ecf0c2bec8f47c88c61 SHA512 9f458491d90b847c896416666cbd1517a1833d355ed0e59df6ae00603ef53383434f02eeb8a31069efeb9a99b1b93abd0a9b7647c9e2ff67976858be458ac95c
EBUILD poetry-plugin-export-1.6.0.ebuild 723 BLAKE2B 504e7f12c7fe609efade2b0105ddc49cc69280d3e1240e2cce4be7265497c3ee805b073094ccbfd0e8e2ee6af120a2d018cb36f463ba8dc0c0c0a20fbef0b38f SHA512 b5804d9434be05fab7627e5a0d709585c45c1ca0fb62127cd722ed23eeb8aa665db675438efcd5f8e4bb0fc8700bf8bda93a8a018614def8814b4dc6fa265d90
+EBUILD poetry-plugin-export-1.7.0.ebuild 728 BLAKE2B 7a3969c339f00d650a707e710fc640c89681acd8c26593cb888cc89c773fc0f4679092f98519edd33ce010e28bf50a40ecbf6cc21c88c36fb6129d6d3d3c1d0f SHA512 9a6e03c0d96de38ffeb40cca40195ccdfbf98c1a831699e3080ba818caaa704f91145ec01bc18919b7dd8dd6effe34375243b29af89a66b363670039da65193e
MISC metadata.xml 514 BLAKE2B 27e1402c90d372d44302449b8b826a66a9795227e72a6b30ccdc316ff0146bb011b8a9fca613e8675ebe13c360d4ba77b6b30a057981e552e3f5762c3af6e65b SHA512 b214726af4d39d3f9a082d4e09e88d1fc63541f18cbdc31e9ceac88aa01ff44eb52cfbfdcca0994f5fd86b905ebbf39af2b0d083f7bca085c1a52c6cab52b630
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.0.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.0.ebuild
new file mode 100644
index 000000000000..a1e7b242c958
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.8.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/poetry[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest