summaryrefslogtreecommitdiff
path: root/dev-python/poetry-plugin-export/poetry-plugin-export-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
commita25cc082a26782e5d39ded4559c91ff11bc3c299 (patch)
tree6cd0802dd248058d540f1f5f472c5df98216f154 /dev-python/poetry-plugin-export/poetry-plugin-export-1.8.0.ebuild
parentd72a987a342949e200b5e9decbd71f246da53788 (diff)
gentoo auto-resync : 13:05:2024 - 00:01:18
Diffstat (limited to 'dev-python/poetry-plugin-export/poetry-plugin-export-1.8.0.ebuild')
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.8.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.8.0.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.8.0.ebuild
new file mode 100644
index 000000000000..ca9a3d9df723
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.7.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ >=dev-python/poetry-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest