summaryrefslogtreecommitdiff
path: root/dev-python/poetry-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 06:17:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 06:17:35 +0000
commitc24da107a8903eb6e86d811f19448c01fa81ba15 (patch)
tree18d4e577f4494130eaebf6bad5507ccc61b6ee78 /dev-python/poetry-core
parent55b20c97078ded20d0e7c6b3ef33d673c861d8b4 (diff)
gentoo auto-resync : 14:03:2023 - 06:17:35
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest2
-rw-r--r--dev-python/poetry-core/poetry-core-1.5.2.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index 991848b16f30..fff48ed3516c 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1,3 +1,5 @@
DIST poetry-core-1.5.1.gh.tar.gz 479091 BLAKE2B ff59460a75893c18f9ad0063a880b40c6cff108d03c7f7bd16aaab53a72bf8af2c08af949c448e8703390589112e26c19e9ea9ddfaf2bed69791f86293b62b1c SHA512 ffc2cf6a37175feebe6ae926250d20ebf5742f459824f54b7ad8ea0f65c28639ef1e90a3cbd31bf58fca19d45699c5a22a583cefb5d60795d7e92399bdd1a421
+DIST poetry-core-1.5.2.gh.tar.gz 484004 BLAKE2B 56fe974bb37233ee75a220d35dab3d246b9a4145a3abd88981a0c2b9f51cb894b3534746638d7fa75a41451c856261b0b8e737af8778f78fcc9ae894a4b2430f SHA512 e0eab97bcf678f8fd329074d14cb394db8732666b0387384d273db49ec020ff34e15e9982e049bce62e9ba80443404de7646e66433164a2358f9802a8ce2fbb1
EBUILD poetry-core-1.5.1.ebuild 1651 BLAKE2B 8e6adf14cade67cd360743aebc2f4da3c14cefa4b0cf5dab380f6d0d8e46eb36e9c47e31752d8fb46dc5f23927978cf40ddc185c3041bbd197f89564f4e6bda0 SHA512 5decea28fa0bf38b960051a05d676378c4d83ec0ad5cd0323d5d957ee840ca0a2d0ef28ffeae97c61b3e899905cf65ef457cbf02952c6143270653bbf301b61c
+EBUILD poetry-core-1.5.2.ebuild 1659 BLAKE2B e45ac593b72d02c198f208759de6761feae031267e290cbedb9e17c74cdf16921562666eb821b8ae1ff85fa659d32af226c13e3ff4a768019f5f006d701076ad SHA512 14f0b1b97397fd27f5e47b78cd08748c0f7fe848edbbfcfe9bedca1c8eaf3d123542349adedff25f1b500c91dbbfa8b6ea434364fb6556ae81c7cbd3436eaa6e
MISC metadata.xml 382 BLAKE2B 82dfc3f146cf3b669fed67ab2e21694b00d5473fdf855cae9fb3a0481785b32c4cf1ed9743a5d64cd055c1cb544377f936a9ec26c9d1dec2cf5fbef6749f5587 SHA512 032fd4dca8f8138c2b527e517f041889e15600ccca876fc3c9e53050196186ad2a9346168bce9c4bae7ffd8a77ff4dd19cc2559fd1da1fd4c7c181056fd49a13
diff --git a/dev-python/poetry-core/poetry-core-1.5.2.ebuild b/dev-python/poetry-core/poetry-core-1.5.2.ebuild
new file mode 100644
index 000000000000..b8e8dad4b649
--- /dev/null
+++ b/dev-python/poetry-core/poetry-core-1.5.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Poetry PEP 517 Build Backend"
+HOMEPAGE="
+ https://github.com/python-poetry/poetry-core/
+ https://pypi.org/project/poetry-core/
+"
+SRC_URI="
+ https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# check inside src/poetry/core/_vendor/vendor.txt
+# (note that some are indirect deps)
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lark[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pep517[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These "fail" bacause of glob file path resulting from newer versions
+ # in our tree than vendored. But those don't affect anything.
+ tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
+ tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
+)
+
+src_prepare() {
+ # remove vendoring of dependencies
+ rm -r src/poetry/core/_vendor || die
+ sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # needed for migration from <1.1
+ distutils_write_namespace poetry
+ epytest
+}