summaryrefslogtreecommitdiff
path: root/dev-python/poetry-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-31 21:49:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-31 21:49:19 +0000
commitb43ae231a57eccda208f33c4343d956e7f2590f5 (patch)
tree8871b66b51dfb514ef803c4eaf3d1f2cb57c4ee1 /dev-python/poetry-core
parent7e84f2c47ae7a0e8b76fc3080b1c7ee8487ee76b (diff)
gentoo auto-resync : 31:10:2023 - 21:49:19
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest2
-rw-r--r--dev-python/poetry-core/poetry-core-1.8.1.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index b56836f2355d..6e8eac632601 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1,3 +1,5 @@
DIST poetry-core-1.7.0.gh.tar.gz 459637 BLAKE2B af42d3e44ccecfa2746fcde1f7c48a4a6376d3391ebd9b660658593c32058bc812460ed1df4999f18c929724c2750a13b8ca44d92791c34cef8544862e8c061a SHA512 cbad311ed53a4b39b027674e8c76cf8822b0cc33b69eca3d79a31e910111efba5021b156d95f51327dca24d584bd96ec1a8cde23b3912e4ed6ca66b11e1bce9b
+DIST poetry-core-1.8.1.gh.tar.gz 367396 BLAKE2B 0305e4022d91632a5cf68e57df61ee27ff1c7faf53d1be6d63e8f30183af828c5fe8126dbd6326ed7a8b428c107878632c26cc1dc2468161b2b79cfdfa0599f8 SHA512 25b4787f45da88142d8cbdad22a518335a82f24ccdba34112ab0f9be8eb130251211969d9da9422bc89fa3c5990adb4e2cde2e3b6f7a4f57f81c6d2b21cf722f
EBUILD poetry-core-1.7.0.ebuild 1876 BLAKE2B a2b08c67ba6eebd0d7536878dcc4eefed136dd11de898fd9a957880d499a5b167d6d6d19f2e2ea7de599e29e225e695f5e1cb3c0df8a0c2d035fe4e42cf44b6c SHA512 1da70f943bc725ca6dc43fe8f631487778331d4afb90de60a8a133f1ca5d42a371e7163c38c7f6a995bbc50108f60f6b5371a100349adf69f676fe7c6440d6a0
+EBUILD poetry-core-1.8.1.ebuild 1885 BLAKE2B 3b1d7e103598e9e85492fb3c6996b43dc726521070f165b29bc086c23cff58494cc5d0ddea7835dd19ccdfb44dd880efa3d3be195b633d0b1b6d392845324d47 SHA512 1bffea9f224aa0dc8b8159aaf443155cac7b9b1cfb6a5c2ec4c0a57eeb3dbbc8f85df9a51434904a1800053c3fe3680b2416bfce5b6c94b948b2769f0fb898b2
MISC metadata.xml 382 BLAKE2B 82dfc3f146cf3b669fed67ab2e21694b00d5473fdf855cae9fb3a0481785b32c4cf1ed9743a5d64cd055c1cb544377f936a9ec26c9d1dec2cf5fbef6749f5587 SHA512 032fd4dca8f8138c2b527e517f041889e15600ccca876fc3c9e53050196186ad2a9346168bce9c4bae7ffd8a77ff4dd19cc2559fd1da1fd4c7c181056fd49a13
diff --git a/dev-python/poetry-core/poetry-core-1.8.1.ebuild b/dev-python/poetry-core/poetry-core-1.8.1.ebuild
new file mode 100644
index 000000000000..f9b96f26200c
--- /dev/null
+++ b/dev-python/poetry-core/poetry-core-1.8.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1
+
+DESCRIPTION="Poetry PEP 517 Build Backend"
+HOMEPAGE="
+ https://github.com/python-poetry/poetry-core/
+ https://pypi.org/project/poetry-core/
+"
+SRC_URI="
+ https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+# check inside vendors/pyproject.toml
+# (note that some are indirect deps)
+RDEPEND="
+ >=dev-python/fastjsonschema-2.18.0[${PYTHON_USEDEP}]
+ dev-python/lark[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.21[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These "fail" bacause of glob file path resulting from newer versions
+ # in our tree than vendored. But those don't affect anything.
+ tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
+ tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
+)
+
+src_prepare() {
+ # remove vendoring of dependencies
+ rm -r src/poetry/core/_vendor || die
+ sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON} (unported deps)"
+ return
+ fi
+
+ epytest
+}