summaryrefslogtreecommitdiff
path: root/dev-python/poetry-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
commit90a3be9d71a22834f9bc82c072f1b993f9a10e31 (patch)
tree7f86c1f37e857df29494ec91436ca76bed49441a /dev-python/poetry-core
parenta597364520b9291d0b2a23bb007ced022e821d95 (diff)
gentoo auto-resync : 20:08:2023 - 21:42:17
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest2
-rw-r--r--dev-python/poetry-core/poetry-core-1.7.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index 59609da27ad4..c63675c0d864 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1,4 +1,6 @@
AUX poetry-core-1.6.1-pypy3.patch 2127 BLAKE2B 65a7c7540c70502467cc5019e47cb9eef492d69efc8f27e513d5fea6ccaaf1dcb09a30e724e9b539adc4d9dc84d7aac8d9642855916a68ddf8242db7b69d4030 SHA512 8e18dba351b1b2babee0bb40d3c4f22136c78cfb11b45e6113d04596b313a0616dae17afe5326aaced776b35aedaeaf0b9b0cd09463028ecd936b1937899a049
DIST poetry-core-1.6.1.gh.tar.gz 477291 BLAKE2B 4e1bd77302005d344693fe7a08b0c55e8a9ea0aad3112915a18950e40cc51116740b9eff5ae851b1d7280454716e3a86b1d8d37d85749f64fcef3bc726eeaf83 SHA512 53db0e4f4d5bc6ed2b201cd88a84e07dc6421e910292b8b5efb0dcce1af6e8c62836458a6409aac0394b5063b7c4a6be93784b0bce8592d74f61800f54916706
+DIST poetry-core-1.7.0.gh.tar.gz 459637 BLAKE2B af42d3e44ccecfa2746fcde1f7c48a4a6376d3391ebd9b660658593c32058bc812460ed1df4999f18c929724c2750a13b8ca44d92791c34cef8544862e8c061a SHA512 cbad311ed53a4b39b027674e8c76cf8822b0cc33b69eca3d79a31e910111efba5021b156d95f51327dca24d584bd96ec1a8cde23b3912e4ed6ca66b11e1bce9b
EBUILD poetry-core-1.6.1.ebuild 1980 BLAKE2B b1cea95a643036f7c5590a1a6576be6b654412caf4cfd9e617be7e046e28f57b36ceeb3a41a3eb6f12af8b58c8f9eba0cf8e1c7df479136daf0e883d12331d98 SHA512 e0d7370d6805484cb372c2b5a65967239c8037b874f4b75bcdd2f7666ba11e5ab5b9b239741375456858f108dfdf973a6aa14abccae0a28b264ecabddf2a4a99
+EBUILD poetry-core-1.7.0.ebuild 1884 BLAKE2B 9edde61cf917379be7928801ab753dff8964c6d1fc5b6c57f92666315d025e4d4602334521df9bd6c3aae89aa6795e6d822d8bf19b5223d4dc930a4534e36b6b SHA512 5e598b404632e4eb22647bd44251e09b1f11db4fccae7547d9a82574d877eaedb8d0f7855349498ff4d778a6ec6ee15685a5a8baa73bee719061aeeab0d9e0bb
MISC metadata.xml 382 BLAKE2B 82dfc3f146cf3b669fed67ab2e21694b00d5473fdf855cae9fb3a0481785b32c4cf1ed9743a5d64cd055c1cb544377f936a9ec26c9d1dec2cf5fbef6749f5587 SHA512 032fd4dca8f8138c2b527e517f041889e15600ccca876fc3c9e53050196186ad2a9346168bce9c4bae7ffd8a77ff4dd19cc2559fd1da1fd4c7c181056fd49a13
diff --git a/dev-python/poetry-core/poetry-core-1.7.0.ebuild b/dev-python/poetry-core/poetry-core-1.7.0.ebuild
new file mode 100644
index 000000000000..6c7dfcec450c
--- /dev/null
+++ b/dev-python/poetry-core/poetry-core-1.7.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1
+
+DESCRIPTION="Poetry PEP 517 Build Backend"
+HOMEPAGE="
+ https://github.com/python-poetry/poetry-core/
+ https://pypi.org/project/poetry-core/
+"
+SRC_URI="
+ https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+# check inside src/poetry/core/_vendor/vendor.txt
+# (note that some are indirect deps)
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lark[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.21[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These "fail" bacause of glob file path resulting from newer versions
+ # in our tree than vendored. But those don't affect anything.
+ tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
+ tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
+)
+
+src_prepare() {
+ # remove vendoring of dependencies
+ rm -r src/poetry/core/_vendor || die
+ sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON} (unported deps)"
+ return
+ fi
+
+ epytest
+}