summaryrefslogtreecommitdiff
path: root/dev-python/poetry-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
commit4ae4e74a3a13c7c5aaebf61e650538b005204fcb (patch)
tree4abb4271a26b735b28a4eb8b69206cbcc8e7b4e2 /dev-python/poetry-core
parentb2a3508c3634488d32ec5bbe6b4365ab27185ebd (diff)
gentoo auto-resync : 19:09:2022 - 23:22:40
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest2
-rw-r--r--dev-python/poetry-core/poetry-core-1.2.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index 187363756f8c..d9a3f4ec03cb 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1,5 +1,7 @@
DIST poetry-core-1.0.8.gh.tar.gz 414941 BLAKE2B 1f663d927aee1f18a9ff38cbf95809538bf9c9e8079d040c240fbc1ffa9e492c6fd20c69f89ddf7e68ddea05beee3b909fdee02e93f47437fffa687dc492ec9a SHA512 6dfed1e1124c37a5f0ec535ede8848e25466da3df6fa6629f6330ce32f05a4d82725d64407e5bcf294d6e467b52966642505ee29f563d3794c4e7aca78045285
DIST poetry-core-1.1.0.gh.tar.gz 534348 BLAKE2B c5dc37579da5d260577c8027520ee9b4a31ca0c4f20f3dc6f233f4f686060aa2c2ae5af46f1d906939364f26cd04155f2c84dea9d209e8d09564b28c19d2220a SHA512 ac8f9797167572bffaaa955e70ba0ab9a509a26ae7905108b43a211b2c93bf29d418da1154bf08f3b4ff744f88c9d6fd0d58408513ffd30e1c4e309ff2784c08
+DIST poetry-core-1.2.0.gh.tar.gz 536297 BLAKE2B 0ba82bfa320d65ce794a4f2346198d252139c03960298ede02f55d8b23367e05e9336b3d5030032b1feab4ffa327974af26ce2918d4d40889f68fbec79ccb490 SHA512 f6d79d7d66a25aa127b5decf46df861ecc101af0438b892196505b4ece5cc55f6ff8796eb603789b3259d213162236b7698305523b2eda414ad1f3a5b659eab9
EBUILD poetry-core-1.0.8.ebuild 1593 BLAKE2B b118fba68c03afda98f3bc816c1e6f0c484808bc1fcfdc92f308d3b8cd4140fb212cebe8fb0eb6f8c6493ea4fbfa4b04ac6ac021ffcfbf3566db1c87d4d07404 SHA512 09b736b8a4d2cc54a85063f48e8a6782dab52f6227aa4e71238d522adce5e174356345541e6ab8558f4c4f59c5d2ee829cc8f273cfd21961974aa0639682f276
EBUILD poetry-core-1.1.0.ebuild 1628 BLAKE2B d21b2534abea4c369eeadde7fd2d2ff6a1b1baf557a44454fbbc5dbd8ba506656aae294a35b64efa5f33127a76ad9ec32b71c0105bd3a90e2e58bd9253e724e9 SHA512 fe519e3c99aa9daf15bc60f3074b492381cd54a86bf915399ee45f54b6765412a653a537ace5fe817f01bb3dcb6143618ee80f7a3714f8837b6ccb6440a44c0e
+EBUILD poetry-core-1.2.0.ebuild 1628 BLAKE2B d21b2534abea4c369eeadde7fd2d2ff6a1b1baf557a44454fbbc5dbd8ba506656aae294a35b64efa5f33127a76ad9ec32b71c0105bd3a90e2e58bd9253e724e9 SHA512 fe519e3c99aa9daf15bc60f3074b492381cd54a86bf915399ee45f54b6765412a653a537ace5fe817f01bb3dcb6143618ee80f7a3714f8837b6ccb6440a44c0e
MISC metadata.xml 382 BLAKE2B 82dfc3f146cf3b669fed67ab2e21694b00d5473fdf855cae9fb3a0481785b32c4cf1ed9743a5d64cd055c1cb544377f936a9ec26c9d1dec2cf5fbef6749f5587 SHA512 032fd4dca8f8138c2b527e517f041889e15600ccca876fc3c9e53050196186ad2a9346168bce9c4bae7ffd8a77ff4dd19cc2559fd1da1fd4c7c181056fd49a13
diff --git a/dev-python/poetry-core/poetry-core-1.2.0.ebuild b/dev-python/poetry-core/poetry-core-1.2.0.ebuild
new file mode 100644
index 000000000000..c76206f1717a
--- /dev/null
+++ b/dev-python/poetry-core/poetry-core-1.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Poetry PEP 517 Build Backend"
+HOMEPAGE="
+ https://github.com/python-poetry/poetry-core/
+ https://pypi.org/project/poetry-core/
+"
+SRC_URI="
+ https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# check inside src/poetry/core/_vendor/vendor.txt
+# (note that some are indirect deps)
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lark[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pep517[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These "fail" bacause of glob file path resulting from newer versions
+ # in our tree than vendored. But those don't affect anything.
+ tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
+ tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
+)
+
+src_prepare() {
+ # remove vendoring of dependencies
+ rm -r src/poetry/core/_vendor || die
+ sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # needed for migration from <1.1
+ distutils_write_namespace poetry
+ epytest
+}