summaryrefslogtreecommitdiff
path: root/dev-python/poetry-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/poetry-core
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest4
-rw-r--r--dev-python/poetry-core/poetry-core-1.0.7.ebuild55
-rw-r--r--dev-python/poetry-core/poetry-core-1.0.8.ebuild2
3 files changed, 2 insertions, 59 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index f56f16671f9a..1ace4929c24d 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1,5 +1,3 @@
-DIST poetry-core-1.0.7.gh.tar.gz 414539 BLAKE2B 570f13e3c7298fd822a38b75c49c623bde4fa780b3787c3c9cfa3939bb68fee3eeaf6190013117a6e751cb6f87a15b343ba183529fcc07d30e37988097954d4a SHA512 40a8b17ae7c51135eb5f96ec76426f075075de7dafff8ab828fe3b47d13759856a7fd2e7504c1216c4f942befde2c6d42c3976978202ce7aa224e966162bd8e5
DIST poetry-core-1.0.8.gh.tar.gz 414941 BLAKE2B 1f663d927aee1f18a9ff38cbf95809538bf9c9e8079d040c240fbc1ffa9e492c6fd20c69f89ddf7e68ddea05beee3b909fdee02e93f47437fffa687dc492ec9a SHA512 6dfed1e1124c37a5f0ec535ede8848e25466da3df6fa6629f6330ce32f05a4d82725d64407e5bcf294d6e467b52966642505ee29f563d3794c4e7aca78045285
-EBUILD poetry-core-1.0.7.ebuild 1587 BLAKE2B 4f22087b53306f616440cdddf15f91d99fc947074590ad9d9d5792c85930f94c029910cc3b0155e6134e6b5cd9169fe9f604d6344db82beff45bad97f8457f44 SHA512 c46836a71188470e34d16c7042bd3646a492cf67e674471457f23b3c54ff953a1bace2df7bacbe5dbfb12fa3d7a55b297eb88f58b125880a6fc5204489c623ca
-EBUILD poetry-core-1.0.8.ebuild 1595 BLAKE2B 8ca9ffee78fcd4df8670a885e03a7d1228892b1742720a7ae507b6ce0a317e40afd16fef86fb134b61aa1e60dd6f0a0f6e7960436041386100d20c8a33c197f8 SHA512 2499f4b1b7b46b6ceaeb7859ff27cb5a52c201e4fe92e984ca5888a1d8ad2648dd1e5743db65940695c3f894587d6602a08280db8a7dd2df8398ed739b07d044
+EBUILD poetry-core-1.0.8.ebuild 1587 BLAKE2B 4f22087b53306f616440cdddf15f91d99fc947074590ad9d9d5792c85930f94c029910cc3b0155e6134e6b5cd9169fe9f604d6344db82beff45bad97f8457f44 SHA512 c46836a71188470e34d16c7042bd3646a492cf67e674471457f23b3c54ff953a1bace2df7bacbe5dbfb12fa3d7a55b297eb88f58b125880a6fc5204489c623ca
MISC metadata.xml 382 BLAKE2B 82dfc3f146cf3b669fed67ab2e21694b00d5473fdf855cae9fb3a0481785b32c4cf1ed9743a5d64cd055c1cb544377f936a9ec26c9d1dec2cf5fbef6749f5587 SHA512 032fd4dca8f8138c2b527e517f041889e15600ccca876fc3c9e53050196186ad2a9346168bce9c4bae7ffd8a77ff4dd19cc2559fd1da1fd4c7c181056fd49a13
diff --git a/dev-python/poetry-core/poetry-core-1.0.7.ebuild b/dev-python/poetry-core/poetry-core-1.0.7.ebuild
deleted file mode 100644
index e8241366bd28..000000000000
--- a/dev-python/poetry-core/poetry-core-1.0.7.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Poetry PEP 517 Build Backend"
-HOMEPAGE="https://pypi.org/project/poetry-core/ https://github.com/python-poetry/poetry-core"
-SRC_URI="
- https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# check inside src/poetry/core/_vendor/vendor.txt
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/lark-parser[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pep517[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Those "fail" bacause of glob file path resulting from newer versions
- # in our tree than vendored. But those don't affect anything.
- tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
- tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
-)
-
-src_prepare() {
- # remove vendoring of dependencies
- rm -r poetry/core/_vendor || die
- sed -e '/__vendor_site__/d' -i poetry/core/__init__.py || die
-
- distutils-r1_src_prepare
-}
diff --git a/dev-python/poetry-core/poetry-core-1.0.8.ebuild b/dev-python/poetry-core/poetry-core-1.0.8.ebuild
index f59ecf0e02e4..e8241366bd28 100644
--- a/dev-python/poetry-core/poetry-core-1.0.8.ebuild
+++ b/dev-python/poetry-core/poetry-core-1.0.8.ebuild
@@ -16,7 +16,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
# check inside src/poetry/core/_vendor/vendor.txt
RDEPEND="