summaryrefslogtreecommitdiff
path: root/dev-python/pockets/pockets-0.9.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-01 09:25:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-01 09:25:36 +0100
commit9b9c22874161d13ca8d50c952d549f2390f3f179 (patch)
tree008ed76c56f51f6f3c30370c7b6109476f3dd4e4 /dev-python/pockets/pockets-0.9.1-r3.ebuild
parent51f111b675c30c05f05128be7836616634098bae (diff)
gentoo auto-resync : 01:06:2023 - 09:25:35
Diffstat (limited to 'dev-python/pockets/pockets-0.9.1-r3.ebuild')
-rw-r--r--dev-python/pockets/pockets-0.9.1-r3.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/pockets/pockets-0.9.1-r3.ebuild b/dev-python/pockets/pockets-0.9.1-r3.ebuild
index f39fc6248076..39add067ef57 100644
--- a/dev-python/pockets/pockets-0.9.1-r3.ebuild
+++ b/dev-python/pockets/pockets-0.9.1-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -12,7 +12,11 @@ inherit distutils-r1
COMMIT="777724c8eabaf76f6d0c5e4837c982d110509b2e"
DESCRIPTION="Collection of helpful Python tools"
-HOMEPAGE="https://pockets.readthedocs.io/ https://pypi.org/project/pockets/"
+HOMEPAGE="
+ https://pockets.readthedocs.io/
+ https://github.com/RobRuana/pockets/
+ https://pypi.org/project/pockets/
+"
SRC_URI="
https://github.com/RobRuana/pockets/archive/${COMMIT}.tar.gz
-> ${P}.gh.tar.gz
@@ -23,9 +27,13 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~x86 ~amd64-linux ~x86-linux"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
BDEPEND="
- test? ( dev-python/pytz[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
"
distutils_enable_tests pytest