summaryrefslogtreecommitdiff
path: root/dev-python/pockets/pockets-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pockets/pockets-0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pockets/pockets-0.3.ebuild')
-rw-r--r--dev-python/pockets/pockets-0.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pockets/pockets-0.3.ebuild b/dev-python/pockets/pockets-0.3.ebuild
new file mode 100644
index 000000000000..51e8ddb01a74
--- /dev/null
+++ b/dev-python/pockets/pockets-0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+IUSE="test"
+
+DESCRIPTION="A collection of helpful Python tools"
+HOMEPAGE="https://pypi.python.org/pypi/pockets"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.3.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+
+"
+src_prepare() {
+ epatch "${FILESDIR}/no_installed_tests.patch" || die
+}
+python_test() {
+ nosetests tests || die "tests failed with ${EPYTHON}"
+}