summaryrefslogtreecommitdiff
path: root/dev-python/plyvel/plyvel-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/plyvel/plyvel-1.3.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/plyvel/plyvel-1.3.0.ebuild')
-rw-r--r--dev-python/plyvel/plyvel-1.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/plyvel/plyvel-1.3.0.ebuild b/dev-python/plyvel/plyvel-1.3.0.ebuild
new file mode 100644
index 000000000000..b49ff2018566
--- /dev/null
+++ b/dev-python/plyvel/plyvel-1.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to LevelDB"
+HOMEPAGE="https://github.com/wbolster/plyvel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/leveldb-1.20:="
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_test() {
+ # With the default import mode, plyvel is imported from ${S} which causes
+ # a failure because it doesn't contain the compiled _plyvel extension
+ pytest --import-mode=append -vv || die "Tests fail with ${EPYTHON}"
+}