summaryrefslogtreecommitdiff
path: root/dev-python/ply/ply-3.11-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/ply/ply-3.11-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/ply/ply-3.11-r2.ebuild')
-rw-r--r--dev-python/ply/ply-3.11-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/ply/ply-3.11-r2.ebuild b/dev-python/ply/ply-3.11-r2.ebuild
new file mode 100644
index 000000000000..0b251f5d8eb4
--- /dev/null
+++ b/dev-python/ply/ply-3.11-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Lex-Yacc library"
+HOMEPAGE="
+ http://www.dabeaz.com/ply/
+ https://github.com/dabeaz/ply/
+ https://pypi.org/project/ply/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+DOCS=( ANNOUNCE CHANGES TODO )
+
+PATCHES=(
+ "${FILESDIR}/3.6-picklefile-IOError.patch"
+)
+
+python_test() {
+ # Checks for pyc/pyo files
+ local -x PYTHONDONTWRITEBYTECODE=
+
+ cd test || die
+ local t
+ for t in testlex.py testyacc.py; do
+ "${EPYTHON}" "${t}" -v || die "${t} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && dodoc -r example
+ distutils-r1_python_install_all
+}